summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Ostrovsky <david@ostrovsky.org>2013-10-27 23:12:14 +0100
committerMichael Stahl <mstahl@redhat.com>2013-11-02 05:43:38 -0500
commit2c92030ff07aff9b10e49844343390925b81545c (patch)
tree384cf5b8ed3bc1da3ea19f330ccba511baac0d58 /configure.ac
parent78e4b97a18a18f84c228de64fc48cee48138fbfe (diff)
Kill servlet-api and tomcat
Change-Id: I630da3fa37144b2e5fb5117017f43841ba89c42a Reviewed-on: https://gerrit.libreoffice.org/6454 Tested-by: LibreOffice gerrit bot <gerrit@libreoffice.org> Reviewed-by: Michael Stahl <mstahl@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac33
1 files changed, 0 insertions, 33 deletions
diff --git a/configure.ac b/configure.ac
index e7f7812fc15d..6c1dd73e0b72 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1611,16 +1611,6 @@ AC_ARG_WITH(commons-logging-jar,
[Specify path to jarfile manually.]),
COMMONS_LOGGING_JAR=$withval)
-AC_ARG_WITH(system-servlet-api,
- AS_HELP_STRING([--with-system-servlet-api],
- [Use servlet-api already on system.]),,
- [with_system_servlet_api="$with_system_jars"])
-
-AC_ARG_WITH(servlet-api-jar,
- AS_HELP_STRING([--with-servlet-api-jar=JARFILE],
- [Specify path to jarfile manually.]),
- SERVLETAPI_JAR=$withval)
-
AC_ARG_WITH(system-jfreereport,
AS_HELP_STRING([--with-system-jfreereport],
[Use JFreeReport already on system.]),,
@@ -10410,29 +10400,6 @@ else
fi
AC_SUBST(ENABLE_MEDIAWIKI)
-if test "$ENABLE_MEDIAWIKI" = "TRUE"; then
- AC_MSG_CHECKING([which Servlet API Jar to use])
- if test "$with_system_servlet_api" = "yes"; then
- AC_MSG_RESULT([external])
- SYSTEM_SERVLETAPI=YES
- if test -z "$SERVLETAPI_JAR"; then
- for version in '' -3.3 -3.2 -3.1 -3.0 -2.5 -2.4; do
- if test -r "/usr/share/java/servlet-api${version}.jar"; then
- SERVLETAPI_JAR=/usr/share/java/servlet-api${version}.jar
- fi
- done
- fi
- AC_CHECK_FILE($SERVLETAPI_JAR, [],
- [AC_MSG_ERROR(servlet-api.jar not found.)], [])
- else
- AC_MSG_RESULT([internal])
- SYSTEM_SERVLETAPI=NO
- BUILD_TYPE="$BUILD_TYPE TOMCAT"
- fi
-fi
-AC_SUBST(SYSTEM_SERVLETAPI)
-AC_SUBST(SERVLETAPI_JAR)
-
AC_MSG_CHECKING([whether to build the Report Builder])
if test "$enable_report_builder" != "no" -a "$with_java" != "no"; then
AC_MSG_RESULT([yes])