summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2018-06-15 15:26:14 +0300
committerTor Lillqvist <tml@collabora.com>2018-06-15 16:23:03 +0200
commit434c730a889685ecf2df068dcf2db65124f9b8d6 (patch)
treee8a2652f1923ba7d5e149331d6303df3c769ac8a /configure.ac
parent0d2c5e0838906101e1fdea93b4a0c422690e331c (diff)
Don't croak on --without-lang
Change-Id: I23e21b5d108fcc4bfc4422bebbc50389565e36fb Reviewed-on: https://gerrit.libreoffice.org/55864 Reviewed-by: Tor Lillqvist <tml@collabora.com> Tested-by: Tor Lillqvist <tml@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c0ff933ca4dd..724de9449c03 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11949,6 +11949,13 @@ AC_MSG_CHECKING([which languages to be built])
ALL_LANGS="en-US $completelangiso"
# check the configured localizations
WITH_LANG="$with_lang"
+
+# Check for --without-lang which turns up as $with_lang being "no". Luckily there is no language with code "no".
+# (Norwegian is "nb" and "nn".)
+if test "$WITH_LANG" = "no"; then
+ WITH_LANG=
+fi
+
if test -z "$WITH_LANG" -o "$WITH_LANG" = "en-US"; then
AC_MSG_RESULT([en-US])
else