summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2022-12-22 09:29:25 +0100
committerStephan Bergmann <sbergman@redhat.com>2022-12-22 09:42:45 +0000
commit482d86c493fd01b4c559436030738480792f6d47 (patch)
tree74300f8206f45efb82b73b9a90fa765c158dd00f /configure.ac
parent070d655e3fc127da3f2428b3f85f751ce9b8bdd1 (diff)
Latest VS 2022 Preview is 17.5.0 now
...while latest proper VS 2022 is 17.4.3, so my Windows --with-visual-studio=2022preview build inconsistently picked up non-preview standard library headers, and failed Change-Id: I0c198d0f2e848b45afd5ffd09443d9643831f15a Reviewed-on: https://gerrit.libreoffice.org/c/core/+/144734 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 858e2cb3fb12..01219ec033be 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3976,7 +3976,7 @@ map_vs_year_to_version()
2022)
vsversion=17;;
2022preview)
- vsversion=17.4;;
+ vsversion=17.5;;
*)
AC_MSG_ERROR([Assertion failure - invalid argument "$1" to map_vs_year_to_version()]);;
esac
@@ -4095,7 +4095,7 @@ find_msvc()
vcyear=2019
vctoolset=v142
;;
- 17.0 | 17.4)
+ 17.0 | 17.5)
vcyear=2022
vctoolset=v143
;;
@@ -4267,7 +4267,7 @@ if test "$_os" = "WINNT"; then
# are always "better", we list them in reverse chronological order.
case "$vcnumwithdot" in
- 16.0 | 17.0 | 17.4)
+ 16.0 | 17.0 | 17.5)
WINDOWS_SDK_ACCEPTABLE_VERSIONS="10.0 8.1A 8.1 8.0"
;;
esac
@@ -6620,7 +6620,7 @@ find_msms()
msmdir=
case "$VCVER" in
- 16.0 | 17.0 | 17.4)
+ 16.0 | 17.0 | 17.5)
for l in `ls -1 $VC_PRODUCT_DIR/redist/MSVC/`; do
my_msm_dir="$VC_PRODUCT_DIR/redist/MSVC/$l/MergeModules/"
echo "$as_me:$LINENO: looking for $my_msm_dir${my_msm_file}])" >&5
@@ -6656,7 +6656,7 @@ find_msvc_x64_dlls()
msvcdllpath="$VC_PRODUCT_DIR/redist/x64/Microsoft.VC${VCVER}.CRT"
case "$VCVER" in
- 16.0 | 17.0 | 17.4)
+ 16.0 | 17.0 | 17.5)
for crtver in 141 142 143; do
for l in `ls -1 $VC_PRODUCT_DIR/redist/MSVC/`; do
echo "$as_me:$LINENO: testing $VC_PRODUCT_DIR/redist/MSVC/$l/x64/Microsoft.VC$crtver.CRT" >&5