summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKhaled Hosny <khaledhosny@eglug.org>2018-07-07 16:07:05 +0200
committerKhaled Hosny <khaledhosny@eglug.org>2018-07-07 22:27:35 +0200
commit4fe073b563336c1b8bfb97a9addc8fb7a8145858 (patch)
tree79f5a32c902a9de7a4aaaf61f5ebbb639b072f4f /configure.ac
parent614804f034a114544dc14047e72ca18a946fbae3 (diff)
Drop TEST_FONTS_MISSING for HAVE_MORE_FONTS
TEST_FONTS_MISSING is just adding confusion since it tests for hardcoded font names, while what we really want (most of time) is to check whether bundled fonts are enabled or not, and HAVE_MORE_FONTS just does that. Change-Id: I1b00d359c37fa49584ca27c319d6d0e937c3b20b Reviewed-on: https://gerrit.libreoffice.org/57136 Tested-by: Jenkins Reviewed-by: Khaled Hosny <khaledhosny@eglug.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac57
1 files changed, 0 insertions, 57 deletions
diff --git a/configure.ac b/configure.ac
index 9a00abdb812f..8c82c17f0ce6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11435,43 +11435,6 @@ fi
AC_SUBST(OPENSYMBOL_TTF)
AC_SUBST(FONTFORGE)
-TEST_FONTS_MISSING=0
-
-# $1 = font family
-# $2+ = accepted font mappings
-test_font_map()
-{
- FONT="$1" ; shift
- FONT_LOWER="$(echo "$FONT" | $AWK '{print tolower($0)}')"
- AC_MSG_CHECKING([font mapping for '$FONT'])
- FONTFILE="$(basename `$FCMATCH -f '%{file}' "$FONT"`)"
- FONTFILE_LOWER="$(echo "$FONTFILE" | $AWK '{print tolower($0)}')"
-
- CURRENT_FONT_FOUND=0
- if test "${FONTFILE_LOWER}" = "${FONT_LOWER}".ttf
- then
- CURRENT_FONT_FOUND=1
- else
- while test "$#" -ge 1 ; do
- MAPPING_LOWER="$(echo "$1" | $AWK '{print tolower($0)}')"; shift
- if test \( "${FONTFILE_LOWER}" = "${MAPPING_LOWER}"-regular.ttf \) -o \
- \( "${FONTFILE_LOWER}" = "${MAPPING_LOWER}".ttf \)
- then
- CURRENT_FONT_FOUND=1
- break
- fi
- done
- fi
- if test $CURRENT_FONT_FOUND -eq 1
- then
- AC_MSG_RESULT([ok])
- else
- AC_MSG_RESULT([unknown map '$FONTFILE'])
- add_warning "unknown map '$FONTFILE' for '$FONT'"
- TEST_FONTS_MISSING=1
- fi
-}
-
dnl ===================================================================
dnl Test whether to include fonts
dnl ===================================================================
@@ -11485,27 +11448,8 @@ else
AC_MSG_RESULT([no])
WITH_FONTS=
SCPDEFS="$SCPDEFS -DWITHOUT_FONTS"
- if test "$test_fontconfig" = "yes"; then
- AC_PATH_PROG([FCMATCH], [fc-match])
- if test -z "$FCMATCH"; then
- AC_MSG_WARN([Unable to query installed fonts - unit tests disabled.])
- TEST_FONTS_MISSING=1
- else
- test_font_map 'Calibri' 'Carlito'
- test_font_map 'DejaVuSans' 'DejaVuSans'
- test_font_map 'Linux Libertine G' 'LinLibertine_R_G'
- if test ${TEST_FONTS_MISSING} -eq 1
- then
- AC_MSG_WARN([Unknown font mappings - unit tests disabled.])
- add_warning "Unknown font mappings - unit tests disabled."
- fi
- fi
- else
- TEST_FONTS_MISSING=1
- fi
fi
AC_SUBST(WITH_FONTS)
-AC_DEFINE_UNQUOTED([TEST_FONTS_MISSING], $TEST_FONTS_MISSING)
dnl ===================================================================
@@ -12906,7 +12850,6 @@ AC_CONFIG_HEADERS([config_host/config_gtk3_kde5.h])
AC_CONFIG_HEADERS([config_host/config_oox.h])
AC_CONFIG_HEADERS([config_host/config_options.h])
AC_CONFIG_HEADERS([config_host/config_options_calc.h])
-AC_CONFIG_HEADERS([config_host/config_test.h])
AC_CONFIG_HEADERS([config_host/config_typesizes.h])
AC_CONFIG_HEADERS([config_host/config_vendor.h])
AC_CONFIG_HEADERS([config_host/config_vcl.h])