summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBalázs Varga (allotropia) <balazs.varga.extern@allotropia.de>2022-11-10 13:52:21 +0100
committerBalazs Varga <balazs.varga.extern@allotropia.de>2022-11-21 11:18:35 +0100
commit6edd93671c491938e52fce75a64f48f8a63d08a1 (patch)
tree41c9fb2aa2dff9eca32b0880f1820d94a4aa5c81 /configure.ac
parent19d02a1267cfa1e7a950af31a77d4a7888594630 (diff)
Revert "use uname for detecting WSL"
Since this patch breaks WSL2 builds on windows. This reverts commit 5a8a1c4a86938b65c5ea7807f60e721946d7d8de. Change-Id: Idd68a2609b81881af87ae777b5c4bf9cc2d8ef88 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/142580 Tested-by: Jenkins Reviewed-by: Balazs Varga <balazs.varga.extern@allotropia.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index cef05a5893d9..52476b46d14a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -302,9 +302,9 @@ dnl checks build and host OSes
dnl do this before argument processing to allow for platform dependent defaults
dnl ===================================================================
-# Check for WSL. But if --host is explicitly specified (to really do build for
+# Check for WSL (version 2, at least). But if --host is explicitly specified (to really do build for
# Linux on WSL) trust that.
-if test -z "$host" -a -z "$build" -a "$(uname -r | grep -i Microsoft 2>/dev/null)" != ""; then
+if test -z "$host" -a -z "$build" -a "`wslsys -v 2>/dev/null`" != ""; then
ac_cv_host="x86_64-pc-wsl"
ac_cv_host_cpu="x86_64"
ac_cv_host_os="wsl"