summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2014-11-26 22:30:33 +0200
committerTor Lillqvist <tml@collabora.com>2014-11-28 10:22:45 +0200
commit7920af486b7124b85b2eb30c90aa26ddc471bd15 (patch)
tree41e9fcb149e5756da0a950c93008e15214738f79 /configure.ac
parent8d239f25a22523a35d862db18341606440ae5473 (diff)
Work in progress: Move Calc-independend OpenCL configuration out of sc
Intermediate commit. More changes will follow: The device selection logic needs to be moved, too. (And cleaned up.) Instead of the separate formulacalculationoptions dialog we should simply have a normal options page for those OpenCL-related settings that will remain purely Calc-specific, like the formula opcode subsetting. Change-Id: Id60d95e80d377cbbf5780beb473b221bce06b5e5
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index c867dc0457b7..efa867b65b85 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10255,13 +10255,13 @@ dnl =================================================
dnl Check whether to build with OpenCL support.
dnl =================================================
-ENABLE_OPENCL=
if test $_os != iOS -a $_os != Android; then
- ENABLE_OPENCL=TRUE
- BUILD_TYPE="$BUILD_TYPE CLCC"
+ # CLCC in BUILD_TYPE tells that we are building a bundled clcc (just the clew part), OPENCL in
+ # BUILD_TYPE tells that OpenCL is potentially available on the platform (optional at run-time,
+ # used through clew).
+ BUILD_TYPE="$BUILD_TYPE CLCC OPENCL"
AC_DEFINE(HAVE_FEATURE_OPENCL)
fi
-AC_SUBST(ENABLE_OPENCL)
dnl ===================================================================
dnl Check whether to enable glTF support