summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2018-08-31 12:07:52 +0200
committerStephan Bergmann <sbergman@redhat.com>2018-08-31 14:27:23 +0200
commit98ad9ec18ee63d6b97b4b90917113656450b81fd (patch)
tree6658ae325594f8f64e510d56efe8deb77e26369d /configure.ac
parent8eca83829b21bf17f6a83b87df38862eab490b30 (diff)
Make --enable-assert-always-abort orthogonal of --enable-debug/dbgutil
(and keep enabled by default iff --enable-debug/dbgutil) Change-Id: I962230b4c6623220603cb713c787c69274f63a8f Reviewed-on: https://gerrit.libreoffice.org/59859 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f4f7303c0146..756261a4f052 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4639,7 +4639,14 @@ AC_SUBST(ENABLE_WERROR)
dnl Check for --enable-assert-always-abort, set ASSERT_ALWAYS_ABORT
dnl ===================================================================
AC_MSG_CHECKING([whether to have assert() failures abort even without --enable-debug])
-if test -n "$enable_assert_always_abort" -a "$enable_assert_always_abort" = "yes"; then
+if test -z "$enable_assert_always_abort"; then
+ if test "$ENABLE_DEBUG" = TRUE; then
+ enable_assert_always_abort=yes
+ else
+ enable_assert_always_abort=no
+ fi
+fi
+if test "$enable_assert_always_abort" = "yes"; then
ASSERT_ALWAYS_ABORT="TRUE"
AC_MSG_RESULT([yes])
else