summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2016-11-25 17:01:49 +0100
committerMichael Stahl <mstahl@redhat.com>2016-11-25 21:55:56 +0000
commit9cd47a6594322b4b77835660c547b25d831f5f4a (patch)
tree6deb6203059ccff3b7b0bcf1a9a2d50313d030ee /configure.ac
parent2ce21dd8b9075486f92c18ac007f61a27062ce63 (diff)
configure: fix harfbuzz build on WNT
The graphite library is always built static, so the graphite headers must be included with the GRAPHITE2_STATIC macro, so that the functions are not marked __declspec(dllimport) on WNT. Add GRAPHITE2_STATIC to GRAPHITE_CFLAGS so harfbuzz picks it up. It's a mystery why vcl even links currently without this. Change-Id: I80d87fe76afa2d05a5697d56dfaf8cbe97d9f977 (cherry picked from commit 086631af59636cd9a6a45b747a1bc59b4b547794) Reviewed-on: https://gerrit.libreoffice.org/31210 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Michael Stahl <mstahl@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 194cbb1e3d18..6e3a992b3f69 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9186,7 +9186,7 @@ AC_SUBST(ICU_LIBS)
dnl ===================================================================
dnl Graphite
dnl ===================================================================
-libo_CHECK_SYSTEM_MODULE([graphite],[GRAPHITE],[graphite2 >= 0.9.3],["-I${WORKDIR}/UnpackedTarball/graphite/include"],["-L${WORKDIR}/LinkTarget/StaticLibrary -lgraphite"])
+libo_CHECK_SYSTEM_MODULE([graphite],[GRAPHITE],[graphite2 >= 0.9.3],["-I${WORKDIR}/UnpackedTarball/graphite/include -DGRAPHITE2_STATIC"],["-L${WORKDIR}/LinkTarget/StaticLibrary -lgraphite"])
if test "$with_system_graphite" = "yes"; then
libo_MINGW_CHECK_DLL([libgraphite2])
fi