summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2016-07-20 17:29:17 +0200
committerNorbert Thiebaud <nthiebaud@gmail.com>2016-07-21 23:29:17 +0000
commitbeccfd1f8d87ae2196815d5a760054312e8e1c38 (patch)
tree14b5ad15fedcc5a8e5f7a67ef2068b5772cdc285 /configure.ac
parentad3f7d1bd65a3ac6295a50171488cef6ebfb0a73 (diff)
gbuild: always set CCACHE_CPP2=1 when COM_IS_CLANG
There are not only spurious warnings from loplugin, but also from plain clang, at least with the Fedora 24 version. So let's just try to always set CCACHE_CPP2=1. This should make the configure check for that obsolete. The check didn't do anything on Fedora anyway because it sets up ccache by putting wrappers like /usr/lib64/ccache/clang on PATH. Change-Id: Ieb17be4a1b1fd0f7aedb16b18cb49015917a26d3 Reviewed-on: https://gerrit.libreoffice.org/27345 Reviewed-by: Norbert Thiebaud <nthiebaud@gmail.com> Tested-by: Norbert Thiebaud <nthiebaud@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 0 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index d93de7908d86..cd7c9c48acb5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3822,18 +3822,6 @@ if test "$COM_IS_CLANG" = TRUE; then
fi
AC_SUBST(COM_IS_CLANG)
-if test "$CCACHE" != "" -a "$COM_IS_CLANG" = TRUE; then
- if test -z "$CCACHE_CPP2"; then
- if test "$enable_ccache" = "" ; then
- AC_MSG_WARN([Using ccache with Clang without CCACHE_CPP2 set causes spurious warnings/errors.])
- add_warning "Using ccache with Clang without CCACHE_CPP2 set causes spurious warnings/errors. Disabling it."
- CCACHE=
- else
- AC_MSG_ERROR([Using --enable-ccache with Clang without CCACHE_CPP2 set causes spurious warnings/errors.])
- fi
- fi
-fi
-
#
# prefix C with ccache if needed
#