summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarkus Mohrhard <markus.mohrhard@collabora.co.uk>2014-04-03 01:05:29 +0200
committerMarkus Mohrhard <markus.mohrhard@collabora.co.uk>2014-04-03 01:10:52 +0200
commitd8ae59e097b3fca29f071d1a792cdb98ad8139cf (patch)
treeaf61bedcedfbcd43d2f27e43c8f72ec34530aae7 /configure.ac
parentd00e9e7fe2ca5e3663befdf986151dd8e2cac9a3 (diff)
add concept for chart xshape tests
will be run on a tinderbox for now that will be the reference for anything related to it Change-Id: Ib795b53f74e9207d0272342f12d426bbc21164b4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3726dfad8f41..940d260f5603 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1130,6 +1130,11 @@ AC_ARG_ENABLE(cve-tests,
[Prevent CVE tests to be executed]),
,)
+AC_ARG_ENABLE(chart-tests,
+ AS_HELP_STRING([--enable-chart-tests],
+ [Executes chart XShape tests]),
+,)
+
AC_ARG_ENABLE(build-unowinreg,
AS_HELP_STRING([--enable-build-unowinreg],
[Do not use the prebuilt unowinreg.dll. Build it instead. The MinGW C++
@@ -9194,6 +9199,18 @@ else
fi
dnl ===================================================================
+dnl Check for enabling chart XShape tests
+dnl ===================================================================
+AC_MSG_CHECKING([whether to execute chart XShape tests])
+if test "$enable_chart_tests" = "yes"; then
+ AC_MSG_RESULT([yes])
+ ENABLE_CHART_TESTS=TRUE
+ AC_SUBST(ENABLE_CHART_TESTS)
+else
+ AC_MSG_RESULT([no])
+fi
+
+dnl ===================================================================
dnl Check for system openssl
dnl ===================================================================
DISABLE_OPENSSL=