summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2012-11-21 10:39:06 +0200
committerTor Lillqvist <tml@iki.fi>2012-11-21 10:39:23 +0200
commite860c78e2390c8d4e924411ac41e045d2a1c3968 (patch)
treec505c822a3a672efc596106294f75b6db6541562 /configure.ac
parent14785648d5534855a0c7f322aa97a7b58a4cb3a8 (diff)
Use subset of ICU data in a bundled ICU
Change-Id: I71673271ec3e10d16f17f5640cbf6a90a1bfb9f4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a121719b5e28..2f1668218a9b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8501,6 +8501,17 @@ else
AC_MSG_RESULT([internal])
SYSTEM_ICU="NO"
ICU_TARBALL="7c53f83e0327343f4060c0eb83842daf-icu4c-49_1_1-src.tgz"
+
+ # Save space when using a bundled ICU by leaving out unneeded parts of the ICU data. Generated by
+ # the interactive web tool at http://apps.icu-project.org/datacustom/ICUData49.html by dropping
+ # the "Charset Mapping Tables". Probably we could carefully cherry-pick other items in the data to
+ # be dropped, too. A bit tedious using that web tool, though.
+
+ # If you do that, upload a new subset data zip file with just the MD5 part of the name changed
+ # appropriately. Let's not bother trying to list what stuff has been removed in the file name.
+ # Describe it in the comment above instead.
+ ICU_DATA_SUBSET_ZIP=fc188d2ed5c2cbcf7a021b34b9f88478-icudt49l-subset.zip
+
BUILD_TYPE="$BUILD_TYPE ICU"
fi
@@ -8516,6 +8527,7 @@ AC_SUBST([ICU_RECLASSIFIED_CONDITIONAL_JAPANESE_STARTER])
AC_SUBST([ICU_RECLASSIFIED_HEBREW_LETTER])
AC_SUBST(ICU_RECLASSIFIED_PREPEND_SET_EMPTY)
AC_SUBST(ICU_TARBALL)
+AC_SUBST(ICU_DATA_SUBSET_ZIP)
AC_SUBST([MINGW_ICUDATA_DLL])
AC_SUBST([MINGW_ICUI18N_DLL])
AC_SUBST([MINGW_ICUUC_DLL])