summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMike Kaganski <mike.kaganski@collabora.com>2023-11-11 16:22:23 +0300
committerMike Kaganski <mike.kaganski@collabora.com>2023-11-11 16:24:57 +0100
commitdb029c5a02880beb262165822a2e833c47569984 (patch)
treed908885b8ec7e0161da46dee5f0e277d1bd64824 /configure.ac
parent619b0fcef2e645347ba959852748614ba8283d88 (diff)
When MPL subset needs to disable icon themes, suggest filtered input
A suggestion like "you wanted to have a, b, c, d; you need to exclude b; use e" makes little sense :-) Change-Id: I0212f0197b89c3e9d281fa5b24708672b82561b8 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/159318 Tested-by: Jenkins Reviewed-by: Mike Kaganski <mike.kaganski@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 545c3de33303..35b654abe1f7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -14765,15 +14765,20 @@ if test "$enable_mpl_subset" = "yes"; then
mpl_error_string="$mpl_error_string$newline Need to disable extra extensions enabled using --enable-ext-XXXX."
fi
denied_themes=
+ filtered_themes=
for theme in $WITH_THEMES; do
case $theme in
breeze|breeze_dark|breeze_dark_svg|breeze_svg|elementary|elementary_svg|karasa_jaga|karasa_jaga_svg) #denylist of icon themes under GPL or LGPL
- denied_themes="$denied_themes $theme" ;;
- *) : ;;
+ denied_themes="${denied_themes:+$denied_themes }$theme" ;;
+ *)
+ filtered_themes="${filtered_themes:+$filtered_themes }$theme" ;;
esac
done
if test "x$denied_themes" != "x"; then
- mpl_error_string="$mpl_error_string$newline Need to disable icon themes from '$WITH_THEMES': $denied_themes present, use --with-theme=colibre."
+ if test "x$filtered_themes" == "x"; then
+ filtered_themes="colibre"
+ fi
+ mpl_error_string="$mpl_error_string$newline Need to disable icon themes: $denied_themes, use --with-theme=$filtered_themes."
fi
ENABLE_OPENGL_TRANSITIONS=