summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorXisco Fauli <xiscofauli@libreoffice.org>2024-06-07 14:35:57 +0200
committerChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2024-06-11 11:48:44 +0200
commit19e9e49bdaeebc314c892c000385ec778edf759b (patch)
tree78a0ca8c033e7d7d0a150972dc3d3dd1dc32289d /configure.ac
parent3f686bfe0e83de59b9f641b08e880c5319f9d8e1 (diff)
python3: upgrade to 3.9.19
Downloaded from https://www.python.org/ftp/python/3.9.19/Python-3.9.19.tar.xz * python-3.8-msvc-sdk.patch.1 is no longer needed * Comment out deprecated warnings for now: C:/cygwin64/home/tdf/jenkins/workspace/gerrit_windows/pyuno/source/module/pyuno_util.cxx(42): error C2220: the following warning is treated as an error C:/cygwin64/home/tdf/jenkins/workspace/gerrit_windows/pyuno/source/module/pyuno_util.cxx(42): warning C4996: 'PyUnicode_FromUnicode': deprecated in 3.3 C:/cygwin64/home/tdf/jenkins/workspace/gerrit_windows/pyuno/source/module/pyuno_util.cxx(64): warning C4996: 'PyUnicode_AsUnicode': deprecated in 3.3 Change-Id: Iaa358ffaaea63cf6ec47914759d0469e70e1cc65 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/168551 Tested-by: Jenkins Reviewed-by: Christian Lohmaier <lohmaier+LibreOffice@googlemail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index edd8191c1e26..8b4a7d0f9560 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10201,7 +10201,7 @@ fi
if test \( "$cross_compiling" = yes -a -z "$PYTHON_FOR_BUILD" \) -o "$enable_python" = internal; then
SYSTEM_PYTHON=
PYTHON_VERSION_MAJOR=3
- PYTHON_VERSION_MINOR=8
+ PYTHON_VERSION_MINOR=9
PYTHON_VERSION=${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}.19
if ! grep -q -i python.*${PYTHON_VERSION} ${SRC_ROOT}/download.lst; then
AC_MSG_ERROR([PYTHON_VERSION ${PYTHON_VERSION} but no matching file in download.lst])