summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2014-02-11 19:04:20 +0100
committerMichael Stahl <mstahl@redhat.com>2014-02-12 09:53:08 +0100
commit23647595d77b85b5dac0d5762987a3ba2533ffd9 (patch)
treef7fe77edb89792eabd184f2d2aa7ec27513b0dfb /configure.ac
parente3abec3f07f2a710bfce66f77b33f494e2aa4972 (diff)
normalize values of SYSTEM_LIBATOMIC_OPS, SYSTEM_FIREBIRD
Change-Id: I89802da0ad7f7bf838a8937430825b0adf42a6ee
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 18def26b0916..c936927ac3dc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8589,7 +8589,7 @@ if test "x$enable_firebird_sdbc" = "xyes"; then
AC_MSG_CHECKING([which Firebird to use])
if test "$with_system_firebird" = "yes"; then
AC_MSG_RESULT([external])
- SYSTEM_FIREBIRD=YES
+ SYSTEM_FIREBIRD=TRUE
AC_PATH_PROG(FIREBIRDCONFIG, [fb_config])
if test -z "$FIREBIRDCONFIG"; then
AC_MSG_NOTICE([No fb_config -- using pkg-config])
@@ -8635,11 +8635,11 @@ if test "x$enable_firebird_sdbc" = "xyes"; then
dnl ===================================================================
libo_CHECK_SYSTEM_MODULE([libatomic_ops],[ATOMIC_OPS],[atomic_ops >= 0.7.2])
if test "$with_system_libatomic_ops" = "yes"; then
- SYSTEM_LIBATOMIC_OPS=YES
+ SYSTEM_LIBATOMIC_OPS=TRUE
AC_CHECK_HEADERS(atomic_ops.h, [],
[AC_MSG_ERROR(atomic_ops.h not found. install libatomic-ops)], [])
else
- SYSTEM_LIBATOMIC_OPS=NO
+ SYSTEM_LIBATOMIC_OPS=
LIBATOMIC_OPS_CFLAGS="-I${WORKDIR}/UnpackedTarball/libatomic_ops/include"
LIBATOMIC_OPS_LIBS="-latomic_ops"
BUILD_TYPE="$BUILD_TYPE LIBATOMIC_OPS"
@@ -8647,7 +8647,7 @@ if test "x$enable_firebird_sdbc" = "xyes"; then
fi
AC_MSG_RESULT([internal])
- SYSTEM_FIREBIRD=NO
+ SYSTEM_FIREBIRD=
FIREBIRD_CFLAGS="-I${WORKDIR}/UnpackedTarball/firebird/include"
FIREBIRD_LIBS="-lfbembed"