summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <michael.stahl@allotropia.de>2024-07-19 13:10:51 +0200
committerChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2024-07-23 14:07:21 +0200
commit2974781f54c68a1d67129cda978667baab6fb5fe (patch)
tree6b7b884d091b54aedc2f74613b6103baee1ff2db /configure.ac
parent69e84cd448e359bf63ead6ed647c380b6ddc2c6c (diff)
configure,curl: enable GSSAPI on Linux/MacOS/etc.
This will link libgssapi_krb5.so.2 which is in krb5-libs (ABI CL1 in RHEL8, ABI CL2 in RHEL9). Change-Id: I2dbaa64e70f4502c5a47c6c85123c94b9ad41277 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/170758 Tested-by: Jenkins Reviewed-by: Michael Stahl <michael.stahl@allotropia.de> (cherry picked from commit 46e21942bf412eda1750f850c328cb41f1ff70ca) Reviewed-on: https://gerrit.libreoffice.org/c/core/+/170731 Reviewed-by: Christian Lohmaier <lohmaier+LibreOffice@googlemail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 14 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1c5d0eb7a45c..d473c88cf2c0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1060,6 +1060,7 @@ ios*) # iOS
test_libcmis=no
test_openldap=no
test_webdav=no
+ with_gssapi=no
if test -n "$LODE_HOME" ; then
mac_sanitize_path
AC_MSG_NOTICE([sanitized the PATH to $PATH])
@@ -1157,6 +1158,7 @@ linux-android*)
test_openldap=no
test_system_freetype=no
test_webdav=no
+ with_gssapi=no
disable_database_connectivity_dependencies
enable_lotuswordpro=no
enable_mpl_subset=yes
@@ -2777,7 +2779,7 @@ AC_ARG_WITH(locales,
,)
# Kerberos and GSSAPI used only by PostgreSQL as of LibO 3.5
-# and also by Mariadb/Mysql since LibO 24.8
+# and also by Mariadb/Mysql and libcurl since LibO 24.8
libo_FUZZ_ARG_WITH(krb5,
AS_HELP_STRING([--with-krb5],
[Enable MIT Kerberos 5 support in modules that support it.
@@ -10742,6 +10744,17 @@ dnl Check for system curl
dnl ===================================================================
libo_CHECK_SYSTEM_MODULE([curl],[CURL],[libcurl >= 7.68.0],enabled)
+if test "$enable_curl" = "yes" -a "$with_system_curl" != "yes" -a "$with_gssapi" != "no"; then
+ if test "$_os" != "WINNT"; then
+ WITH_GSSAPI=TRUE
+ save_LIBS=$LIBS
+ AC_SEARCH_LIBS(gss_init_sec_context, [gssapi_krb5 gss 'gssapi -lkrb5 -lcrypto'], [],
+ [AC_MSG_ERROR([could not find function 'gss_init_sec_context' required for GSSAPI])])
+ GSSAPI_LIBS=$LIBS
+ LIBS=$save_LIBS
+ fi
+fi
+
dnl ===================================================================
dnl Check for system boost
dnl ===================================================================