summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2024-05-07 14:19:50 +0200
committerChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2024-05-07 17:08:44 +0200
commit83d3f9b819ee23efa314953fc2fde4412d90a60b (patch)
treed8d600c1674ca6d45864e25ebfbf57c71647ac63 /configure.ac
parentfbd8cfb046fd0882402e01c2e0b2955e6972737f (diff)
use windows doxygen in wsl-as-helper case
basically reverts f7fe6a0bed2c2aee19535a26181a2edfb103e587 avoiding the penalty for accessing files in the windows-realm from within the wsl-container significantly accelerates the doc-generation Change-Id: I95af905bda7225a9c1924a41e952656dffbfbc0b Reviewed-on: https://gerrit.libreoffice.org/c/core/+/167279 Tested-by: Jenkins Reviewed-by: Christian Lohmaier <lohmaier+LibreOffice@googlemail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 16 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index e04f4a846642..5954533a7f1b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9488,8 +9488,9 @@ else
fi
else
AC_MSG_CHECKING([for doxygen])
- DOXYGEN=$with_doxygen
- AC_MSG_RESULT([$DOXYGEN])
+ PathFormat "$with_doxygen"
+ DOXYGEN="$formatted_path_unix"
+ AC_MSG_RESULT([$formatted_path])
fi
if test -n "$DOXYGEN"; then
DOXYGEN_VERSION=`$DOXYGEN --version 2>/dev/null`
@@ -9498,6 +9499,19 @@ else
AC_MSG_ERROR([found doxygen is too old; need at least version 1.8.4 or specify --without-doxygen])
fi
fi
+ if test -n "$WSL_ONLY_AS_HELPER"; then
+ dnl what really should be tested is whether it is doxygen from windows-realm
+ dnl i.e. one that runs on the windows-side and deals with windows-pathnames
+ dnl using doxygen from wsl container would be possible, but there's a performance
+ dnl penalty when accessing the files outside the container
+ AC_MSG_CHECKING([whether doxygen is a windows executable])
+ if $(file "$DOXYGEN" | grep -q "PE32"); then
+ AC_MSG_RESULT([yes])
+ else
+ AC_MSG_RESULT([no])
+ AC_MSG_ERROR([please provide a path to a windows version of doxygen or use --without-doxygen])
+ fi
+ fi
fi
fi
AC_SUBST([DOXYGEN])