summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2020-09-22 22:39:59 +0300
committerTor Lillqvist <tml@collabora.com>2020-09-22 22:44:08 +0200
commitd4105c8aec2e1815aa536c50bc742dd5c8bff940 (patch)
treeb2caf2c4941417f72f2cbbba400d88ab777d247e /configure.ac
parent84d20cdc64035af829c568dc7f5b9af625b5b54b (diff)
Use sed syntax that isn't GNU-specific
Fix fallout from 63972e79bbb9ea9654e755381641052632b0402c. Change-Id: Ie11514eb396fdc68e05ee180322df27e29ede03f Reviewed-on: https://gerrit.libreoffice.org/c/core/+/103216 Tested-by: Jenkins Reviewed-by: Tor Lillqvist <tml@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a8c2e37a726c..d57d80ef56f1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5024,7 +5024,8 @@ if test "$cross_compiling" = "yes"; then
# converts BUILD_TYPE and PERMITTED_BUILD_TARGETS into non-whitespace,
# newlined lists, to use grep as a filter
PERMITTED_BUILD_TARGETS=$(echo "$PERMITTED_BUILD_TARGETS" | sed -e '/^ *$/d' -e 's/ *//')
- BUILD_TARGETS="$(sed -ne '/^export BUILD_TYPE=/ { s/.*=// ; s/ /\n/gp }' config_host.mk)"
+ BUILD_TARGETS="$(sed -n -e '/^export BUILD_TYPE=/ s/.*=//p' config_host.mk | sed -e 's/ /\
+/')"
BUILD_TARGETS="$(echo "$BUILD_TARGETS" | grep -F "$PERMITTED_BUILD_TARGETS" | tr '\n' ' ')"
sed -i -e "s/ BUILD_TYPE=.*$/ BUILD_TYPE=$BUILD_TARGETS/" config_host.mk