summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCaolán McNamara <caolan.mcnamara@collabora.com>2024-06-06 16:37:49 +0100
committerCaolán McNamara <caolan.mcnamara@collabora.com>2024-06-06 21:08:42 +0200
commitdc346060164e800c7fed7859b17c19ddd2e027c9 (patch)
treedfec2a35f0508650b83c4b9a6a0419acdc533e2f /configure.ac
parent69ebf09889c551c41aac951d2df97ff0e75d841c (diff)
drop searching for widget extended tips in the offline help
by now these extended tips for the widgets of the general ui appear in the .ui file directly instead as accessibility descriptions instead. In any case, the default build configs of distro-configs/LibreOfficeLinux.conf distro-configs/LibreOfficeMacOSX.conf distro-configs/LibreOfficeWin64.conf use --with-help=html where these ahelps are not available. So, existing in the classic help only. Change-Id: Ie27736e9140e445c7f8986a741c2002f2efa9ccb Reviewed-on: https://gerrit.libreoffice.org/c/core/+/168505 Tested-by: Jenkins Reviewed-by: Caolán McNamara <caolan.mcnamara@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 5 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index b221ab89a713..3f9805e4ff82 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5711,7 +5711,7 @@ dnl ===================================================================
ENABLE_HTMLHELP=
HELP_OMINDEX_PAGE=
HELP_ONLINE=
-ENABLE_LOCALHELP=
+WITH_HELPPACKS=
AC_MSG_CHECKING([which help to build])
if test -n "$with_help" -a "$with_help" != "no"; then
@@ -5720,7 +5720,7 @@ if test -n "$with_help" -a "$with_help" != "no"; then
case "$with_help" in
"html")
ENABLE_HTMLHELP=TRUE
- ENABLE_LOCALHELP=TRUE
+ WITH_HELPPACKS=TRUE
SCPDEFS="$SCPDEFS -DWITH_HELPPACKS"
AC_MSG_RESULT([HTML (local)])
;;
@@ -5730,7 +5730,7 @@ if test -n "$with_help" -a "$with_help" != "no"; then
AC_MSG_RESULT([HTML (online)])
;;
yes)
- ENABLE_LOCALHELP=TRUE
+ WITH_HELPPACKS=TRUE
SCPDEFS="$SCPDEFS -DWITH_HELPPACKS"
AC_MSG_RESULT([XML (local)])
;;
@@ -5787,7 +5787,7 @@ fi
dnl Test whether to integrate helppacks into the product's installer
AC_MSG_CHECKING([for helppack integration])
-if test -z "$ENABLE_LOCALHELP" -o "$with_helppack_integration" = no; then
+if test -z "$WITH_HELPPACKS" -o "$with_helppack_integration" = no; then
AC_MSG_RESULT([no integration])
else
SCPDEFS="$SCPDEFS -DWITH_HELPPACK_INTEGRATION"
@@ -5797,9 +5797,7 @@ fi
AC_SUBST([ENABLE_HTMLHELP])
AC_SUBST([HELP_OMINDEX_PAGE])
AC_SUBST([HELP_ONLINE])
-if test "$ENABLE_LOCALHELP" = "TRUE" ; then
- AC_DEFINE(HAVE_FEATURE_LOCAL_HELP)
-fi
+# WITH_HELPPACKS is used only in configure
dnl ===================================================================
dnl Set up a different compiler to produce tools to run on the build