summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorXisco Fauli <xiscofauli@libreoffice.org>2022-07-13 13:53:06 +0200
committerXisco Fauli <xiscofauli@libreoffice.org>2022-07-13 17:09:02 +0200
commitfad98d4d2c6726fb5b30233cfe8c0cfe1a5f18c0 (patch)
tree555ffb48e2060d743d2079ad84b13fddbe605fb8 /configure.ac
parentc605283ad6785dea762feab5fdffd9d27e75c292 (diff)
Remove unused --enable-chart-tests
On 2022-07-04 I submitted 268f0f3f0d70902acaeb3f99e0d206ad66ffd67c "run CppunitTest_chart2_xshape without ENABLE_CHART_TESTS" to see if CppunitTest_chart2_xshape would fail for anyone. Since then, no one has complained about it, so I suppose the tests are stable nowadays, thus removing --enable-chart-tests which does nothing since the mentioned commit Change-Id: I0407c0379ea45eee93bd6689c90d1759b48e2844 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/137022 Tested-by: Jenkins Reviewed-by: Xisco Fauli <xiscofauli@libreoffice.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 0 insertions, 20 deletions
diff --git a/configure.ac b/configure.ac
index 08395ac66677..87f4f7fa7a1e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1777,14 +1777,6 @@ libo_FUZZ_ARG_ENABLE(cve-tests,
[Prevent CVE tests to be executed]),
,)
-libo_FUZZ_ARG_ENABLE(chart-tests,
- AS_HELP_STRING([--enable-chart-tests],
- [Executes chart XShape tests. In a perfect world these tests would be
- stable and everyone could run them, in reality it is best to run them
- only on a few machines that are known to work and maintained by people
- who can judge if a test failure is a regression or not.]),
-,)
-
AC_ARG_ENABLE(build-opensymbol,
AS_HELP_STRING([--enable-build-opensymbol],
[Do not use the prebuilt opens___.ttf. Build it instead. This needs
@@ -11008,18 +11000,6 @@ else
fi
dnl ===================================================================
-dnl Check for enabling chart XShape tests
-dnl ===================================================================
-AC_MSG_CHECKING([whether to execute chart XShape tests])
-if test "$enable_chart_tests" = "yes" -o '(' "$_os" = "WINNT" -a "$enable_chart_tests" != "no" ')'; then
- AC_MSG_RESULT([yes])
- ENABLE_CHART_TESTS=TRUE
- AC_SUBST(ENABLE_CHART_TESTS)
-else
- AC_MSG_RESULT([no])
-fi
-
-dnl ===================================================================
dnl Check for system openssl
dnl ===================================================================
ENABLE_OPENSSL=