summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2020-12-18 16:23:59 +0100
committerChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2020-12-19 00:25:51 +0100
commit315c7570c4a72f4c834086082825533b1e50d1bf (patch)
tree99f1f71131cad17c258d71ed4a9e43902b8ba03c /configure.ac
parent4db61e4cb26a8bf739701876aa806479a61bb447 (diff)
cross-compile: make sure configure fails if build-side configure fails
testing for existance of config_host.mk is flawed/doesn't catch all kind of errors and thus gives false "OK" for incremental builds and not even for builds after make clean see also d691b46e52d173cf945130df01bd35b5c4c0f539 Change-Id: I153f585c3a7870ef4a87848eccf7abd7d66987e2 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/107970 Tested-by: Jenkins Reviewed-by: Christian Lohmaier <lohmaier+LibreOffice@googlemail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 89c44b74e4f9..29d553b7c198 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5226,7 +5226,9 @@ if test "$cross_compiling" = "yes"; then
$sub_conf_opts \
--srcdir=$srcdir \
2>&1 | sed -e 's/^/ /'
- test -f ./config_host.mk 2>/dev/null || exit
+ if test [${PIPESTATUS[0]}] -ne 0; then
+ AC_MSG_ERROR([Running the configure script for BUILD side failed, see CONF-FOR-BUILD/config.log])
+ fi
# filter permitted build targets
PERMITTED_BUILD_TARGETS="
@@ -5346,7 +5348,7 @@ if test "$cross_compiling" = "yes"; then
done
)
- test -f CONF-FOR-BUILD/build-config || AC_MSG_ERROR([Running configure script for BUILD system failed, see CONF-FOR-BUILD/config.log])
+ test -f CONF-FOR-BUILD/build-config || AC_MSG_ERROR([setup/configure for BUILD side failed, see CONF-FOR-BUILD/config.log])
test -f config_build.mk || AC_MSG_ERROR([A file called config_build.mk was supposed to have been copied here, but it isn't found])
perl -pi -e 's,/(workdir|instdir)(/|$),/\1_for_build\2,g;' \
-e 's,/CONF-FOR-BUILD,,g;' config_build.mk