summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKhaled Hosny <khaled@aliftype.com>2022-08-01 00:23:22 +0200
committerCaolán McNamara <caolanm@redhat.com>2022-08-05 09:51:37 +0200
commitb7c1f13eca14836ce3427afb79cae1101661461c (patch)
treef853d95915d4d18ffc26b153080cc8242be2a125 /configure.ac
parentf705132f20eb9e0cbe57f11f1f9594a287a63900 (diff)
vcl: Add a configure option to set VCL_FLOAT_DEVICE_PIXEL
Disabled by default. It might improve sub-pixel glyph positioning a bit, though it is only used inside VCL and the API boundary is still sal_Int32, sound rounding to full pixels still happens at some point. Change-Id: I702f9a521e5b556d198756d6cdbb455ebaffbab4 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/137664 Tested-by: Jenkins Reviewed-by: Caolán McNamara <caolanm@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 12 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 80150dcb725c..851c2afe9b94 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2039,6 +2039,11 @@ AC_ARG_ENABLE(customtarget-components,
AS_HELP_STRING([--enable-customtarget-components],
[Generates the static UNO object constructor mapping from the build.]))
+AC_ARG_ENABLE(float_device_pixel,
+ AS_HELP_STRING([--enable-float-device-pixel],
+ [Uses doubles for VCL device coordinates instead of 32-bit integers.]),
+,)
+
dnl ===================================================================
dnl Optional Packages (--with/without-)
dnl ===================================================================
@@ -11666,14 +11671,13 @@ dnl ===================================================================
dnl Set vcl option: coordinate device in double or sal_Int32
dnl ===================================================================
-dnl disabled for now, we don't want subtle differences between OSs
-dnl AC_MSG_CHECKING([Type to use for Device Pixel coordinates])
-dnl if test "$_os" = "Darwin" -o $_os = iOS ; then
-dnl AC_DEFINE(VCL_FLOAT_DEVICE_PIXEL)
-dnl AC_MSG_RESULT([double])
-dnl else
-dnl AC_MSG_RESULT([sal_Int32])
-dnl fi
+AC_MSG_CHECKING([Type to use for Device Pixel coordinates])
+if test "$enable_float_device_pixel" = yes; then
+ AC_DEFINE(VCL_FLOAT_DEVICE_PIXEL)
+ AC_MSG_RESULT([double])
+else
+ AC_MSG_RESULT([sal_Int32])
+fi
dnl ===================================================================
dnl Show which vclplugs will be built.