summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSakura286 <sakura286@outlook.com>2022-07-26 02:18:23 +0000
committerStephan Bergmann <sbergman@redhat.com>2022-11-10 13:47:06 +0100
commitbc9487f745befde6534fd46058e119256952323d (patch)
tree10b4ac8fd4be55ff19da95d39a51da7e753b6cd6 /configure.ac
parent7ac572437ac972ef37aed8003f5a476f49b27b89 (diff)
Add riscv64 support
1. Configure gbuild 2. Add UNO Bridge for riscv64 Till now base function works well on riscv64. The bridgetest has passed. Test on Debian, Gentoo and openEuler. Credits: - Heiher <r@hev.cc> and Stephan Bergmann <sbergman@redhat.com> The riscv64 bridge implementation refers to mips64 and AArch64 bridges. - Bo Yu <tsu.yubo@gmail.com> configures gbuild for riscv64. - WANG Xuerui <xen0n@gentoo.org> provides lots of guiding tips. Change-Id: Ifad3b0de8b2c9e7328627ed03396bbd45a9c71e4 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/137445 Reviewed-by: Stephan Bergmann <sbergman@redhat.com> Tested-by: Jenkins
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 8 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 08c2ac634b71..a3f00fddd585 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5265,6 +5265,12 @@ linux-gnu*|linux-musl*)
EPM_FLAGS="-a mipsel"
PLATFORMID=linux_mips_el
;;
+ riscv64)
+ CPUNAME=RISCV64
+ RTL_ARCH=RISCV64
+ EPM_FLAGS="-a riscv64"
+ PLATFORMID=linux_riscv64
+ ;;
m68k)
CPUNAME=M68K
RTL_ARCH=M68K
@@ -8675,7 +8681,7 @@ if test "$ENABLE_JAVA" != ""; then
JAVAINTERPRETER=`win_short_path_for_make "$JAVAINTERPRETER"`
elif test "$cross_compiling" != "yes"; then
case $CPUNAME in
- AARCH64|AXP|X86_64|IA64|POWERPC64|S390X|SPARC64|MIPS64)
+ AARCH64|AXP|X86_64|IA64|POWERPC64|S390X|SPARC64|MIPS64|RISCV64)
if test -f "$JAVAINTERPRETER" -a "`$JAVAINTERPRETER -version 2>&1 | $GREP -i 64-bit`" = "" >/dev/null; then
AC_MSG_WARN([You are building 64-bit binaries but the JDK $JAVAINTERPRETER is 32-bit])
AC_MSG_ERROR([You should pass the --with-jdk-home option pointing to a 64-bit JDK])
@@ -12949,7 +12955,7 @@ AC_SUBST(RHINO_JAR)
# platforms there.
supports_multilib=
case "$host_cpu" in
-x86_64 | powerpc64 | powerpc64le | s390x | aarch64 | mips64 | mips64el | loongarch64)
+x86_64 | powerpc64 | powerpc64le | s390x | aarch64 | mips64 | mips64el | loongarch64 | riscv64)
if test "$SAL_TYPES_SIZEOFLONG" = "8"; then
supports_multilib="yes"
fi