summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tlillqvist@suse.com>2012-12-06 02:33:46 +0200
committerTor Lillqvist <tlillqvist@suse.com>2012-12-06 02:37:31 +0200
commit1a65a1b4fb54583a1fb1e5b6e7325bfc8a210c34 (patch)
tree21996f7aefe6a9be26e39f89ee4dc4ea56e30c16 /configure.ac
parent8e43393c9514f39e6b43e581503b61177a00bd36 (diff)
Set OOO_VENDOR to the login name as fallback
If OOO_VENDOR is empty you get annoying warnings from the Windows Resource Compiler at line 55 in solenv/inc/shlinfo.rc.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7a9648531a6e..55ca717ff2d5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11866,7 +11866,17 @@ AC_SUBST(EXTRA_BUILDID)
OOO_VENDOR=
AC_MSG_CHECKING([for vendor])
if test -z "$with_vendor" -o "$with_vendor" = "no"; then
- AC_MSG_RESULT([not set])
+ OOO_VENDOR="$USERNAME"
+
+ if test -z "$OOO_VENDOR"; then
+ OOO_VENDOR="$USER"
+ fi
+
+ if test -z "$OOO_VENDOR"; then
+ OOO_VENDOR="`id -u -n`"
+ fi
+
+ AC_MSG_RESULT([not set, using $OOO_VENDOR])
else
OOO_VENDOR="$with_vendor"
AC_MSG_RESULT([$OOO_VENDOR])