summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Holesovsky <kendy@collabora.com>2014-10-01 17:01:59 +0200
committerJan Holesovsky <kendy@collabora.com>2014-10-01 17:04:07 +0200
commit25b110cd13b63310a41d5edbda36a8871349858d (patch)
tree9dc8fb906c9028e2976fd4f5861208ffa078cc12 /configure.ac
parent66feae0c9171a9a366dc6af3b3690358a1ef11e8 (diff)
android: android:debuggable setting now depends on configure options.
Change-Id: I12d9c05fb05e4cf202c5c0d7b7e87c145d163fea
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 93fc82518c83..4e2eec999fe4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3760,15 +3760,19 @@ if test -n "$ENABLE_DBGUTIL"; then
AC_MSG_ERROR([--disable-debug cannot be used with --enable-dbgutil])
fi
ENABLE_DEBUG="TRUE"
+ ANDROID_DEBUGGABLE='android:debuggable="true"'
AC_MSG_RESULT([yes (dbgutil)])
elif test -n "$enable_debug" && test "$enable_debug" != "no"; then
ENABLE_DEBUG="TRUE"
+ ANDROID_DEBUGGABLE='android:debuggable="true"'
AC_MSG_RESULT([yes])
else
ENABLE_DEBUG=""
+ ANDROID_DEBUGGABLE=""
AC_MSG_RESULT([no])
fi
AC_SUBST(ENABLE_DEBUG)
+AC_SUBST(ANDROID_DEBUGGABLE)
dnl Selective debuginfo
ENABLE_DEBUGINFO_FOR=
@@ -4419,6 +4423,7 @@ if test "$cross_compiling" = "yes"; then
bin/get_config_variables \
solenv/bin/getcompver.awk \
solenv/inc/langlist.mk \
+ android/experimental/LOAndroid3/AndroidManifest.xml.in \
config_host.mk.in \
Makefile.in \
lo.xcent.in \
@@ -12779,7 +12784,8 @@ if test -f config_host.mk; then
config_md5=`$MD5SUM config_host.mk | sed "s/ .*//"`
fi
-AC_CONFIG_FILES([config_host.mk
+AC_CONFIG_FILES([android/experimental/LOAndroid3/AndroidManifest.xml
+ config_host.mk
Makefile
lo.xcent
instsetoo_native/util/openoffice.lst