summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndras Timar <atimar@suse.com>2012-12-12 10:07:35 +0100
committerAndras Timar <atimar@suse.com>2012-12-14 12:20:13 +0100
commitc7b1a2fe811f1d5a233cd790cec9067cea246845 (patch)
tree7d7a4ea48a67b54f8d1848e75db97341fdbf4275 /configure.ac
parenta9a734a680dda8c177f92cf2f14061c9b785ec8d (diff)
Make KeyID (qtz) work again
Conflicts: configure.ac Change-Id: I67b2ce4ae647150aeace72c542a5838940d2c058
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 320384cabc35..63e14794c022 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11829,7 +11829,11 @@ AC_MSG_CHECKING([which languages to be built])
# + removes en-US; we want to put it on the beginning
# + prints just the section starting with 'completelangiso=' and ending with the " at the end of line
[eval $(sed -e :a -e '/\\$/N; s/\\\n//; ta' -n -e 's/=/="/;s/\([^\\]\)$/\1"/;s/en-US//;/^completelangiso/p' $SRC_ROOT/solenv/inc/langlist.mk)]
-ALL_LANGS="en-US $completelangiso"
+if test "$enable_release_build" = "" -o "$enable_release_build" = "no"; then
+ ALL_LANGS="en-US $completelangiso qtz"
+else
+ ALL_LANGS="en-US $completelangiso"
+fi
# check the configured localizations
WITH_LANG="$with_lang"
if test -z "$WITH_LANG" -o "$WITH_LANG" = "en-US"; then
@@ -11853,10 +11857,11 @@ for lang in $WITH_LANG; do
done
# list with substituted ALL
WITH_LANG_LIST=`echo $WITH_LANG | sed "s/ALL/$ALL_LANGS/"`
-# this variable is used only by bin/distro-install-* helper scripts
-# they need a real list of languages
test -z "$WITH_LANG_LIST" && WITH_LANG_LIST="en-US"
test "$WITH_LANG" = "en-US" && WITH_LANG=
+if test "$enable_release_build" = "" -o "$enable_releasbie_build" = "no"; then
+ test "$WITH_LANG_LIST" = "en-US" || WITH_LANG_LIST=`echo $WITH_LANG_LIST qtz`
+fi
AC_SUBST(ALL_LANGS)
AC_SUBST(WITH_LANG)
AC_SUBST(WITH_LANG_LIST)