summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFridrich Štrba <fridrich.strba@bluewin.ch>2012-12-07 09:40:39 +0100
committerFridrich Štrba <fridrich.strba@bluewin.ch>2012-12-07 09:40:39 +0100
commitebff822d9338eb8739922d5b18baef875ba8d966 (patch)
tree87b4c715a24a0249c7591e88fbc6039ebed66029 /configure.ac
parent549b5d030ab60dbf6d0279634b22702e70078dd8 (diff)
Add --enable-windows-build-signing option
Change-Id: I9630a486043c97aa9e31873c63f807cedb869a24
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index add83643ea71..8186eb626f76 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1059,6 +1059,11 @@ AC_ARG_ENABLE(release-build,
See http://wiki.documentfoundation.org/DevBuild]),
,)
+AC_ARG_ENABLE(windows-build-signing,
+ AS_HELP_STRING([--enable-windows-build-signing],
+ [Enable signing of windows binaries (*.exe, *.dll)]),
+,)
+
AC_ARG_ENABLE(silent-msi,
AS_HELP_STRING([--enable-silent-msi],
[Enable MSI with LIMITUI=1 (silent install).]),
@@ -2106,6 +2111,19 @@ fi
AC_SUBST(ENABLE_RELEASE_BUILD)
dnl ===================================================================
+dnl Test whether to sign Windows Build
+dnl ===================================================================
+AC_MSG_CHECKING([whether to sign windows build])
+if test "$enable_windows_build_signing" = "yes" -a "$_os" = "WINNT" -a "$WITH_MINGW" != "YES" ; then
+ AC_MSG_RESULT([yes])
+ WINDOWS_BUILD_SIGNING="TRUE"
+else
+ AC_MSG_RESULT([no])
+ WINDOWS_BUILD_SIGNING="FALSE"
+fi
+AC_SUBST(WINDOWS_BUILD_SIGNING)
+
+dnl ===================================================================
dnl MacOSX build and runtime environment options
dnl ===================================================================