summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2013-05-02 20:17:20 +0300
committerTor Lillqvist <tml@iki.fi>2013-05-02 20:19:15 +0300
commit7de37ac7d633ba12cd90a38b2255130ef8e88b1a (patch)
tree222bcdd1ffab75bdbc479d6143d9f894792ffec9 /configure.ac
parente8177f99008ee24283e0506e296edb59a16ff8d6 (diff)
Add --enable-desktop-gui-elements to show such even on non-DESKTOP platforms
Not my idea. Change-Id: If4874d97a2035588cd65ded9f281de0c3598b7d7
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 25fc5cd086e5..83b2d6a531a5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1123,6 +1123,12 @@ AC_ARG_ENABLE(silent-msi,
[Enable MSI with LIMITUI=1 (silent install).]),
,)
+AC_ARG_ENABLE(desktop-gui-elements,
+ AS_HELP_STRING([--enable-desktop-gui-elements],
+ [Enable display and use of desktop style GUI elements
+ even on a non-desktop platform.]),
+,)
+
AC_ARG_ENABLE(macosx-code-signing,
AS_HELP_STRING([--enable-macosx-code-signing<=identity>],
[Sign executables, dylibs, frameworks and the app bundle. The
@@ -2141,7 +2147,10 @@ dnl cross-compiling would imply a non-desktop OS.
if test $_os != iOS -a $_os != Android; then
BUILD_TYPE="$BUILD_TYPE DESKTOP"
AC_DEFINE(HAVE_FEATURE_DESKTOP)
+ AC_DEFINE(HAVE_FEATURE_DESKTOP_GUI_ELEMENTS)
AC_DEFINE(HAVE_FEATURE_MULTIUSER_ENVIRONMENT)
+elif test "$enable_desktop_gui_elements" = yes; then
+ AC_DEFINE(HAVE_FEATURE_DESKTOP_GUI_ELEMENTS)
fi
DISABLE_EXPORT=''