summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Tardon <dtardon@redhat.com>2013-06-07 10:40:54 +0200
committerDavid Tardon <dtardon@redhat.com>2013-06-07 10:45:53 +0200
commitc20f79d8dabf1e7035ecad09dc46486412c1b332 (patch)
treede86a8f917c19dd60f09f00ded093df42a5f5da9 /configure.ac
parentd28bb70875e9191ff20b6b5751695f583b73a4f0 (diff)
simplify check for harfbuzz
We check for it in both branches of the if, right? So why do not drop it entirely? (cherry picked from commit 36edf2e6fff430beeb35882b408ceb01453a9e18) Signed-off-by: David Tardon <dtardon@redhat.com> Conflicts: configure.ac Change-Id: I715bfb55c02c5425bbb4874b97aca9d2872acced
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 3 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 6462857e77cf..8c7999de62e8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8393,14 +8393,10 @@ AC_MSG_CHECKING([whether to enable HarfBuzz support])
if test "$_os" != "WINNT" -a "$_os" != "Darwin"; then
AC_MSG_RESULT([yes])
ENABLE_HARFBUZZ="TRUE"
- if test "$with_system_harfbuzz" = "yes"; then
- if $PKG_CONFIG --atleast-version 0.9.18 harfbuzz; then
- libo_CHECK_SYSTEM_MODULE([harfbuzz],[HARFBUZZ],[harfbuzz-icu >= 0.9.18])
- else
- libo_CHECK_SYSTEM_MODULE([harfbuzz],[HARFBUZZ],[harfbuzz >= 0.9.10])
- fi
+ if $PKG_CONFIG --atleast-version 0.9.18 harfbuzz; then
+ libo_CHECK_SYSTEM_MODULE([harfbuzz],[HARFBUZZ],[harfbuzz-icu >= 0.9.18])
else
- libo_CHECK_SYSTEM_MODULE([harfbuzz],[HARFBUZZ],[harfbuzz >= 0.9.10])
+ libo_CHECK_SYSTEM_MODULE([harfbuzz],[HARFBUZZ],[harfbuzz >= 0.9.10])
fi
else
AC_MSG_RESULT([no])