summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuboš Luňák <l.lunak@collabora.com>2014-03-23 15:58:00 +0100
committerLuboš Luňák <l.lunak@collabora.com>2014-03-23 16:26:56 +0100
commitf605cfc73d918c5ba38c988619e0a52472a589d8 (patch)
tree3d94ea33d5bfc41a9c05b1fe9517a9b74062d220 /configure.ac
parentf7859e52829a44e04692653079aea3a5df4579da (diff)
make it possible to build without the obnoxious forced -j to make
Rework --with-parallelism to not add any extra -j to make if 0 or --without is used. This requires explicit -j usage, which - builds even compilerplugins in parallel - builds 'make -C sw/' in parallel (since you don't forget the -j) - avoids jobserver disabling if -j is explicitly passed to the toplevel make IMO this is just a relic of the old build system and the option should be dumped altogether, but I don't feel like arguing right now. Change-Id: I71479391bcfc84aa5e9fd9696880702da496d45c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 7 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 89a816687984..016bb166b553 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12373,7 +12373,7 @@ AC_MSG_CHECKING([for number of processors to use])
# plain --with-parallelism is just the default
if test -n "$with_parallelism" -a "$with_parallelism" != "yes"; then
if test "$with_parallelism" = "no"; then
- PARALLELISM=1
+ PARALLELISM=0
else
PARALLELISM=$with_parallelism
fi
@@ -12397,10 +12397,7 @@ else
esac
# If we hit the catch-all case, but /proc/cpuinfo doesn't exist or has an
- # unexpected format, 'wc -l' will have returned 0.
- if test "$PARALLELISM" -eq 0; then
- PARALLELISM=1
- fi
+ # unexpected format, 'wc -l' will have returned 0 (and we won't use -j at all).
fi
fi
@@ -12414,7 +12411,11 @@ if test "$no_parallelism_make" = "YES" && test $PARALLELISM -gt 1; then
fi
fi
-AC_MSG_RESULT([$PARALLELISM])
+if test $PARALLELISM -eq 0; then
+ AC_MSG_RESULT([explicit make -j option needed])
+else
+ AC_MSG_RESULT([$PARALLELISM])
+fi
AC_SUBST(PARALLELISM)
#