summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCaolán McNamara <caolanm@redhat.com>2016-12-05 12:10:47 +0000
committerCaolán McNamara <caolanm@redhat.com>2016-12-05 12:56:27 +0000
commit5ca4a50c17e9637c8b39293ec1d1c50402b563f7 (patch)
tree3bc97c319ef210d83bb2a41a78bb03959a9cbcbf /configure.ac
parent32bdcdd411178a909806905bdee8725e3492dc7f (diff)
optionally enable oss-fuzz targets via --enable-fuzzers
Change-Id: I16f52515a149a1e6e47cd0301a45db84ddd95885
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ba2b359c6478..f26c8673b65a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1049,6 +1049,11 @@ AC_ARG_ENABLE(fetch-external,
[Disables fetching external tarballs from web sources.])
)
+AC_ARG_ENABLE(fuzzers,
+ AS_HELP_STRING([--enable-fuzzers],
+ [Enables building libfuzzer targets for fuzz testing.])
+)
+
AC_ARG_ENABLE(pch,
AS_HELP_STRING([--enable-pch],
[Enables precompiled header support for C++. Forced default on Windows/VC build])
@@ -9206,6 +9211,20 @@ else
fi
AC_SUBST(ENABLE_BREAKPAD)
+dnl ==================================================================
+dnl libfuzzer
+dnl ==================================================================
+AC_MSG_CHECKING([whether to enable fuzzers])
+if test "$enable_fuzzers" != yes; then
+ AC_MSG_RESULT([no])
+else
+ AC_MSG_RESULT([yes])
+ ENABLE_FUZZERS="TRUE"
+ AC_DEFINE(ENABLE_FUZZERS)
+ BUILD_TYPE="$BUILD_TYPE FUZZERS"
+fi
+AC_SUBST(ENABLE_FUZZERS)
+
dnl ===================================================================
dnl Orcus
dnl ===================================================================