summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJan-Marek Glogowski <glogow@fbihome.de>2019-07-09 15:28:29 +0000
committerJan-Marek Glogowski <glogow@fbihome.de>2019-07-21 23:22:46 +0200
commitd3c6ac6d0f23df56644008ccb6aa2c8fa37ab1b5 (patch)
tree8f5e5a004c937d5a85fd66ff72834a977b645ace /configure.ac
parent49d17d392b7c7a309b3d9264643881656d386eb1 (diff)
tdf#125922 rename kde5 to kf5 + plasma5
Just as the gtk3 plugin isn't named GNOME, rename kde5 to kf5, as it is based on the KDE frameworks 5 libraries. This also includes: * a convenience alias to load the kf5 VCL plugin in case someone requests the kde5 plugin. * keep convenience kde5 configure switch, but warn about it * rename detected desktop from kde5 to plasma5 Change-Id: I6764a05b81a5edbf284484c234fee2649aacf735 Reviewed-on: https://gerrit.libreoffice.org/75313 Tested-by: Jenkins Reviewed-by: Jan-Marek Glogowski <glogow@fbihome.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac58
1 files changed, 34 insertions, 24 deletions
diff --git a/configure.ac b/configure.ac
index 2ef45d1cdd7c..0358692fc1d6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -616,7 +616,7 @@ solaris*)
linux-gnu*|k*bsd*-gnu*)
test_gtk=yes
build_gstreamer_1_0=yes
- test_kde5=yes
+ test_kf5=yes
test_gtk3_kde5=yes
test_gdb_index=yes
test_split_debug=yes
@@ -710,7 +710,7 @@ darwin*) # macOS or iOS
freebsd*)
test_gtk=yes
build_gstreamer_1_0=yes
- test_kde5=yes
+ test_kf5=yes
test_gtk3_kde5=yes
test_freetype=yes
AC_MSG_CHECKING([the FreeBSD operating system release])
@@ -738,7 +738,7 @@ freebsd*)
*netbsd*)
test_gtk=yes
build_gstreamer_1_0=yes
- test_kde5=yes
+ test_kf5=yes
test_gtk3_kde5=yes
test_freetype=yes
PTHREAD_LIBS="-pthread -lpthread"
@@ -763,7 +763,7 @@ openbsd*)
dragonfly*)
test_gtk=yes
build_gstreamer_1_0=yes
- test_kde5=yes
+ test_kf5=yes
test_gtk3_kde5=yes
test_freetype=yes
PTHREAD_LIBS="-pthread"
@@ -785,7 +785,7 @@ linux-android*)
test_fontconfig=no
test_freetype=no
test_gtk=no
- test_kde5=no
+ test_kf5=no
test_gtk3_kde5=no
test_randr=no
test_xrender=no
@@ -1271,15 +1271,20 @@ AC_ARG_ENABLE(qt5,
available.]),
,)
-AC_ARG_ENABLE(kde5,
- AS_HELP_STRING([--enable-kde5],
+AC_ARG_ENABLE(kf5,
+ AS_HELP_STRING([--enable-kf5],
[Determines whether to use Qt5/KF5 vclplug on platforms where Qt5 and
KF5 are available.]),
,)
+AC_ARG_ENABLE(kde5,
+ AS_HELP_STRING([--enable-kde5],
+ [Compatibility switch for the kde5 => kf5 rename. Use --enable-kf5!])
+,)
+
AC_ARG_ENABLE(gtk3_kde5,
AS_HELP_STRING([--enable-gtk3-kde5],
- [Determines whether to use Gtk3 vclplug with KDE file dialogs on
+ [Determines whether to use Gtk3 vclplug with KF5 file dialogs on
platforms where Gtk3, Qt5 and Plasma is available.]),
,)
@@ -4911,7 +4916,7 @@ if test "$USING_X11" != TRUE; then
test_dbus=no
test_gtk=no
build_gstreamer_1_0=no
- test_kde5=no
+ test_kf5=no
test_qt5=no
test_gtk3_kde5=no
enable_cairo_canvas=no
@@ -4919,16 +4924,22 @@ fi
if test "$OS" = "HAIKU"; then
enable_cairo_canvas=yes
- test_kde5=yes
+ test_kf5=yes
fi
-if test "$test_kde5" = "yes"; then
+if test "x$enable_kde5" = "xyes"; then
+ AC_MSG_WARN([The kde5 VCL plugin was renamed to kf5. Please update your configuration to use --enable-kf5, as --enable-kde5 will be removed after the next major release!])
+ add_warning "The kde5 VCL plugin was renamed to kf5. Please update your configuration to use --enable-kf5, as --enable-kde5 will be removed after the next major release!"
+ test_kf5=yes
+fi
+
+if test "$test_kf5" = "yes"; then
test_qt5=yes
fi
-if test "$test_kde5" = "yes" -a "$enable_kde5" = "yes"; then
+if test "$test_kf5" = "yes"; then
if test "$enable_qt5" = "no"; then
- AC_MSG_ERROR([KDE5 support depends on QT5, so it conflicts with --disable-qt5])
+ AC_MSG_ERROR([KF5 support depends on QT5, so it conflicts with --disable-qt5])
else
enable_qt5=yes
fi
@@ -10461,13 +10472,13 @@ if test "x$enable_qt5" = "xyes"; then
fi
AC_SUBST(ENABLE_QT5)
-ENABLE_KDE5=""
-if test "x$enable_kde5" = "xyes"; then
- ENABLE_KDE5="TRUE"
- AC_DEFINE(ENABLE_KDE5)
- R="$R kde5"
+ENABLE_KF5=""
+if test "x$enable_kf5" = "xyes"; then
+ ENABLE_KF5="TRUE"
+ AC_DEFINE(ENABLE_KF5)
+ R="$R kf5"
fi
-AC_SUBST(ENABLE_KDE5)
+AC_SUBST(ENABLE_KF5)
ENABLE_GTK3_KDE5=""
if test "x$enable_gtk3_kde5" = "xyes"; then
@@ -11246,7 +11257,7 @@ AC_SUBST(ENABLE_SCRIPTING_JAVASCRIPT)
AC_SUBST(SYSTEM_RHINO)
AC_SUBST(RHINO_JAR)
-# This is only used in Qt5/KDE5 checks to determine if /usr/lib64
+# This is only used in Qt5/KF5 checks to determine if /usr/lib64
# paths should be added to library search path. So lets put all 64-bit
# platforms there.
supports_multilib=
@@ -11271,7 +11282,7 @@ MOC5="moc"
QT5_GOBJECT_CFLAGS=""
QT5_GOBJECT_LIBS=""
QT5_HAVE_GOBJECT=""
-if test \( "$test_kde5" = "yes" -a "$ENABLE_KDE5" = "TRUE" \) -o \
+if test \( "$test_kf5" = "yes" -a "$ENABLE_KF5" = "TRUE" \) -o \
\( "$test_qt5" = "yes" -a "$ENABLE_QT5" = "TRUE" \) -o \
\( "$test_gtk3_kde5" = "yes" -a "$ENABLE_GTK3_KDE5" = "TRUE" \)
then
@@ -11369,14 +11380,13 @@ AC_SUBST(QT5_GOBJECT_LIBS)
AC_SUBST(QT5_HAVE_GOBJECT)
dnl ===================================================================
-dnl KDE5 Integration
+dnl KF5 Integration
dnl ===================================================================
KF5_CFLAGS=""
KF5_LIBS=""
KF5_CONFIG="kf5-config"
-if test \( "$test_kde5" = "yes" -a "$ENABLE_KDE5" = "TRUE" \) -o \
- \( "$test_kf5" = "yes" -a "$ENABLE_KF5" = "TRUE" \) -o \
+if test \( "$test_kf5" = "yes" -a "$ENABLE_KF5" = "TRUE" \) -o \
\( "$test_gtk3_kde5" = "yes" -a "$ENABLE_GTK3_KDE5" = "TRUE" \)
then
if test "$OS" = "HAIKU"; then