summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2015-11-24 12:55:06 +0200
committerTor Lillqvist <tml@collabora.com>2015-11-24 12:58:57 +0200
commit81d9f1cbd634e54719dd288c5b0de2015d563b2a (patch)
tree69c27c4e8dfd98a1bb661f082f1beca1cd590903 /configure.ac
parentbbbef1568bfced7fd351a8df15cc5d8f227b3ace (diff)
Bin outdated #if and unnecessary <config_mingw.h>
We don't support cross-compiling with MinGW currently, and in any case if we ever attempt such again, in the meantime the free replacement Win32 headers most likely have been updated to include the SCRIPT_CONTROL::fMergeNeutralItems field, so no conditional compilation is needed. Change-Id: I38701d6c41c44952466c1ece7c8433abe67642be
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 0 insertions, 22 deletions
diff --git a/configure.ac b/configure.ac
index fd5e1ec4e791..5e52434eef85 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5841,27 +5841,6 @@ using namespace std;
AC_SUBST(MINGW_GXXDLL)
fi
-if test "$_os" = "WINNT" -a "$WITH_MINGW" != "yes"; then
- AC_DEFINE(HAVE_FMERGENEUTRALITEMS)
-fi
-
-if test "$WITH_MINGW" = "yes"; then
- AC_MSG_CHECKING([for fMergeNeutralItems in SCRIPT_CONTROL])
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM(
- [
- #include <usp10.h>
- ],
- [
- SCRIPT_CONTROL c;
- c.fMergeNeutralItems = 1;
- ])],
- [
- AC_MSG_RESULT(yes)
- AC_DEFINE(HAVE_FMERGENEUTRALITEMS)
- ],
- [AC_MSG_RESULT(no)])
-fi
-
dnl *************************************************************
dnl Testing for exception handling - dwarf2 or sjlj exceptions...
dnl *************************************************************
@@ -12970,7 +12949,6 @@ AC_CONFIG_HEADERS([config_host/config_locales.h])
AC_CONFIG_HEADERS([config_host/config_mpl.h])
AC_CONFIG_HEADERS([config_host/config_orcus.h])
AC_CONFIG_HEADERS([config_host/config_kde4.h])
-AC_CONFIG_HEADERS([config_host/config_mingw.h])
AC_CONFIG_HEADERS([config_host/config_oox.h])
AC_CONFIG_HEADERS([config_host/config_opengl.h])
AC_CONFIG_HEADERS([config_host/config_options.h])