summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2014-02-11 15:57:18 +0100
committerMichael Stahl <mstahl@redhat.com>2014-02-12 09:53:08 +0100
commite3abec3f07f2a710bfce66f77b33f494e2aa4972 (patch)
tree740f34ea017abc08ce444b93ccad57a628e4f444 /configure.ac
parentb62f5c2a22d968d06ea9e638126278bbd1158bf6 (diff)
fdo#74825: fix missing lcms2/libxslt/curl in installation sets
The assumption that all configure variables had been normalized to TRUE/<empty> turned out not to hold; convert a bit more in that direction. (regression from 4af38b099c741c3676aefeb20c515913aaeed666) Change-Id: I2127c515e8a833a07c9b26ed9d693ce5a1853fe4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 7 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index a09e177831cf..18def26b0916 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7846,7 +7846,7 @@ dnl ===================================================================
if test "$with_system_lcms2" = "yes"; then
libo_MINGW_CHECK_DLL([liblcms2])
else
- SYSTEM_LCMS2=NO
+ SYSTEM_LCMS2=
fi
libo_CHECK_SYSTEM_MODULE([lcms2],[LCMS2],[lcms2],["-I${WORKDIR}/UnpackedTarball/lcms2/include"],["-L${WORKDIR}/UnpackedTarball/lcms2/src/.libs -llcms2"])
if test "$GCC" = "yes"; then
@@ -7924,7 +7924,7 @@ fi
AC_MSG_CHECKING([which libxslt to use])
if test "$with_system_libxml" = "yes"; then
AC_MSG_RESULT([external])
- SYSTEM_LIBXSLT=YES
+ SYSTEM_LIBXSLT=TRUE
if test "$_os" = "Darwin"; then
dnl make sure to use SDK path
LIBXSLT_CFLAGS="-I$MACOSX_SDK_PATH/usr/include/libxml2"
@@ -7950,7 +7950,7 @@ if test "$with_system_libxml" = "yes"; then
libo_MINGW_TRY_DLL([iconv])
else
AC_MSG_RESULT([internal])
- SYSTEM_LIBXSLT=NO
+ SYSTEM_LIBXSLT=
LIBXSLT_MAJOR=1
BUILD_TYPE="$BUILD_TYPE LIBXSLT"
@@ -8676,7 +8676,7 @@ fi
if test "$with_system_curl" = "yes"; then
AC_MSG_RESULT([external])
- SYSTEM_CURL=YES
+ SYSTEM_CURL=TRUE
AC_MSG_CHECKING([whether libcurl is >= 7.19.4])
@@ -8723,7 +8723,7 @@ elif test $_os = iOS; then
ENABLE_CURL=
else
AC_MSG_RESULT([internal])
- SYSTEM_CURL=NO
+ SYSTEM_CURL=
BUILD_TYPE="$BUILD_TYPE CURL"
ENABLE_CURL=TRUE
fi
@@ -8783,7 +8783,7 @@ dnl ===================================================================
dnl Determine which hash container mdds shall use
dnl ===================================================================
AC_MSG_CHECKING([which hash container mdds shall use])
-if test "x$HAVE_CXX11" = "xTRUE" -a "x$SYSTEM_MDDS" = "xYES"; then
+if test "x$HAVE_CXX11" = "xTRUE" -a "x$SYSTEM_MDDS" = "xTRUE"; then
MDDS_CPPFLAGS=$CXXFLAGS_CXX11
AC_MSG_RESULT([std::unordered_map])
else
@@ -9413,7 +9413,7 @@ if test "$enable_openssl" = "yes"; then
elif test "$_os" = "NetBSD" -o "$_os" = "OpenBSD" -o "$_os" = "DragonFly" \
&& test "$with_system_openssl" != "no"; then
with_system_openssl=yes
- SYSTEM_OPENSSL=YES
+ SYSTEM_OPENSSL=TRUE
OPENSSL_CFLAGS=
OPENSSL_LIBS="-lssl -lcrypto"
else