summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2013-12-17 15:31:24 +0200
committerTor Lillqvist <tml@collabora.com>2013-12-17 15:33:20 +0200
commit05fa566b17902f76343952fb8355d576208fd097 (patch)
tree216e3c46e127c105857a21fa9b928b3dab3d6234 /configure.ac
parent46fcde38cff5f99f98b8e2ca98e6908d647b0423 (diff)
Touch a plain file and not /dev/null to avoid problem on Cygwin at least
Touch the "warn" file that we use to save warnings detected during configury. Change-Id: I44ad9a878f7768af6046337c0465e00061306dda
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ab86c34d17c9..897aac81fabb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9953,7 +9953,7 @@ dnl We need touch with -h option support.
dnl ===================================================================
AC_PATH_PROG(TOUCH, touch)
test -z "$TOUCH" && AC_MSG_ERROR([touch is required])
-if ! "$TOUCH" -h /dev/null 2>/dev/null > /dev/null; then
+if ! "$TOUCH" -h warn 2>/dev/null > /dev/null; then
AC_MSG_ERROR([touch version with -h option support is required to build, please install it and make sure it is the one found first in PATH],,)
fi