summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMiklos Vajna <vmiklos@collabora.com>2020-06-29 16:54:31 +0200
committerMiklos Vajna <vmiklos@collabora.com>2020-07-01 16:35:13 +0200
commitc540483134482d437ea6e02390ff429f4300cbb0 (patch)
treef0dedf9d6f042b4823a8e53aee328d755426586b /configure.ac
parentb551604a81d6cd5ab9b85d56c57a97f4abc457fd (diff)
configure: add a --with-product-flavor switch
Defaults to Personal to point out this is supported by volunteers. This affects the splash screen, the window title, the about dialog and the start center. Change-Id: I216a7f547618377ed268454ebfd2801c4c3901b7 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/97427 Tested-by: Jenkins Reviewed-by: Miklos Vajna <vmiklos@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 15 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b8492f0fc343..d477665acc28 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1504,6 +1504,11 @@ AC_ARG_WITH(product-name,
[Define the product name. Default is AC_PACKAGE_NAME.]),
,with_product_name=$PRODUCTNAME)
+AC_ARG_WITH(product-flavor,
+ AS_HELP_STRING([--with-product-flavor='My Own Personal Flavor'],
+ [Define the product flavor. Default is Personal.]),
+,with_product_flavor=Personal)
+
AC_ARG_WITH(package-version,
AS_HELP_STRING([--with-package-version='3.1.4.5'],
[Define the package version. Default is AC_PACKAGE_VERSION. Use only if you distribute an own build for macOS.]),
@@ -2376,6 +2381,15 @@ fi
AC_SUBST(ENABLE_RELEASE_BUILD)
AC_SUBST(GET_TASK_ALLOW_ENTITLEMENT)
+AC_MSG_CHECKING([for product flavor])
+if test "$with_product_flavor" = "no"; then
+ PRODUCTFLAVOR=""
+elif test -n "$with_product_flavor"; then
+ PRODUCTFLAVOR="$with_product_flavor"
+fi
+AC_MSG_RESULT([$PRODUCTFLAVOR])
+AC_DEFINE_UNQUOTED([PRODUCTFLAVOR], ["$PRODUCTFLAVOR"])
+
dnl ===================================================================
dnl Test whether to sign Windows Build
dnl ===================================================================
@@ -12877,7 +12891,7 @@ dnl ===================================================================
AC_MSG_CHECKING([for alternative branding images directory])
# initialize mapped arrays
BRAND_INTRO_IMAGES="intro.png intro-highres.png"
-brand_files="$BRAND_INTRO_IMAGES logo.svg logo_inverted.svg about.svg"
+brand_files="$BRAND_INTRO_IMAGES logo.svg logo_inverted.svg logo_flavor.svg about.svg"
if test -z "$with_branding" -o "$with_branding" = "no"; then
AC_MSG_RESULT([none])