summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2019-10-08 15:59:17 +0200
committerStephan Bergmann <sbergman@redhat.com>2019-10-08 19:21:30 +0200
commit392f2d64e303cc9a6b6955dfdbde7baea46a6e99 (patch)
tree350860529b3b4b6da388553058c11c40a1b50eba /configure.ac
parentcee1105a7361bd94650deeca39f02539d018a17c (diff)
CXX is now always set before CXX_X64_BINARY on Windows
...since ea3d4e806cbdde18173da92187329f1ac2177e14 "Fix CXX_BASE for clang-cl builds on Windows", as a side effect, moved the conditional CXX=$MSVC_CXX further up. This addresses the comment in the commit message of 463a79cbc16c1b4aba1775d7f8ae0324753c322c "CXX_X64_BINARY must be clang-cl not cl when building with clang-cl": "Ideally, the code would be reorganized so that CXX_X64_BINARY is only set after CXX has been set." Change-Id: Iaa011aeff88669ddd5d33fc5b1109abf02edff54 Reviewed-on: https://gerrit.libreoffice.org/80468 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0943619e7701..5bb1a2029817 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3622,7 +3622,7 @@ if test "$_os" = "WINNT"; then
AC_MSG_WARN([Installation set will not contain 64-bit Explorer extensions])
fi
else
- CXX_X64_BINARY=${CXX:-$MSVC_CXX}
+ CXX_X64_BINARY=$CXX
fi
AC_SUBST(BUILD_X64)