summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2020-01-03 13:55:24 +0200
committerTor Lillqvist <tml@collabora.com>2020-01-03 17:53:00 +0100
commit50b5f0a3cb864f5e58429946098a80235fa528fa (patch)
treeb988baaea8303923eedc9a0675b69ff745e23a0e /configure.ac
parent3f5a4c8cf2e24f5da8319ff43d0b7da431ef6cc0 (diff)
Use only the 'MacOSXSpell' component on iOS, not the 'spell' one
Using only the system spell checker (through MacOSXSpell) is what we have been doing anyway. Do not build the hunspell or mythes externals for iOS. Do not build the lnth or spell components for iOS. Change-Id: I2e2abc268d7719e540072e5daff3f7960e04ed27 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/86172 Reviewed-by: Tor Lillqvist <tml@collabora.com> Tested-by: Tor Lillqvist <tml@collabora.com> Reviewed-on: https://gerrit.libreoffice.org/c/core/+/86174 Tested-by: Jenkins
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 093027bcf524..bc2e5699315b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10172,7 +10172,9 @@ dnl ===================================================================
dnl Check for system hunspell
dnl ===================================================================
AC_MSG_CHECKING([which libhunspell to use])
-if test "$with_system_hunspell" = "yes"; then
+if test "$_os" = iOS; then
+ AC_MSG_RESULT([none])
+elif test "$with_system_hunspell" = "yes"; then
AC_MSG_RESULT([external])
SYSTEM_HUNSPELL=TRUE
AC_LANG_PUSH([C++])
@@ -10271,7 +10273,9 @@ dnl ===================================================================
dnl Checking for mythes
dnl ===================================================================
AC_MSG_CHECKING([which mythes to use])
-if test "$with_system_mythes" = "yes"; then
+if test "$_os" = iOS; then
+ AC_MSG_RESULT([none])
+elif test "$with_system_mythes" = "yes"; then
AC_MSG_RESULT([external])
SYSTEM_MYTHES=TRUE
AC_LANG_PUSH([C++])