summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2013-11-01 12:19:09 +0100
committerMichael Stahl <mstahl@redhat.com>2013-11-02 22:07:53 +0100
commitbc5069ac40a19fc0f421403c9f8ae7e645b34cbb (patch)
tree630f91fad103ece03f8d9e15f6e074dbe8c70a09 /configure.ac
parent64a882888665dcbe15acc5793e7c9cf5f1bdc575 (diff)
remove SOLARENV variable
It is constant and can just be replaced by $(SRCDIR)/solenv. Use BUILD_TYPE where it was used to check if config_*.mk is sourced. Change-Id: Ib9d480c57194b6340093aa47776f8768df69b7d1
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 6c1dd73e0b72..7f992a547e12 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12,6 +12,11 @@ dnl in order to create a configure script.
AC_INIT([LibreOffice],[4.2.0.0.alpha0+],[],[],[http://documentfoundation.org/])
AC_PREREQ([2.59])
+
+if test -n "$BUILD_TYPE"; then
+ AC_MSG_ERROR([You have sourced config_host.mk in this shell. This may lead to trouble, please run in a fresh (login) shell.])
+fi
+
save_CC=$CC
save_CXX=$CXX
@@ -73,10 +78,6 @@ add_warning()
echo "$COLORWARN $@" >> warn
}
-if test -n "$SOLARENV"; then
- AC_MSG_ERROR([You have sourced config_host.mk in this shell. This may lead to trouble, please run in a fresh (login) shell.])
-fi
-
echo "********************************************************************"
echo "*"
echo "* Running ${PACKAGE_NAME} build configuration."