summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2020-10-20 07:59:39 +0200
committerStephan Bergmann <sbergman@redhat.com>2020-10-20 14:35:07 +0200
commit26bb96e3dfbbbdaf0b66e3759d02054d182a50db (patch)
tree5c6c04ae0a7a1cacdf9f91a26cc63b9526750077 /configure.ac
parentfb3c3b2861b6e658c260a22cc58c3f69be327b18 (diff)
Allow to opt in for --enable-gtk3 plus --without-system-cairo
This check had been introduced with 5ad60c5d69042a73d7a1632d3c04e15783817db4 "more configure, and scp2 pieces for gtk3 integration", but without stating any reason. In a comment at <https://gerrit.libreoffice.org/c/core/+/104549/1# message-4b5fcbdabf9c7e40782df682d68efb6282b37c6e> "Allow to opt in for --enable-gtk3 plus --without-system-cairo", mmeeks now states: "My recollection is of horrors with the internal cairo being linked before the system one, and being older - such that various gtk3 themes / bits of functionality which would now link to an older (or even newer ;-) internal cairo randomly stop working / crash / burn / etc." However, at least my Linux build appears to work fine with (among others) --enable-gtk3 --enable-gtk3-kde5 --without-system-cairo And that combination proved useful to me when I wanted to run SAL_USE_VCLPLUGIN=gtk3 LO against a libcairo built with ASan the other day. So, while keeping the default of implicit --with-system-cairo if any of --enable-gtk3 or --enable-gtk3-kde5 is (implicitly) set, lets allow to nevertheless explicitly opt in to that combination---with a prominent warning. Change-Id: Ie5231085966a4f3e35b080ca162d8b846cc1ad34 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/104549 Reviewed-by: Michael Meeks <michael.meeks@collabora.com> Reviewed-by: Stephan Bergmann <sbergman@redhat.com> Tested-by: Jenkins
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 96cf1467dee2..120c531f44a8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11189,7 +11189,7 @@ GTK3_CFLAGS=""
GTK3_LIBS=""
if test "x$enable_gtk3" = "xyes" -o "x$enable_gtk3_kde5" = "xyes"; then
if test "$with_system_cairo" = no; then
- AC_MSG_ERROR([System cairo required for gtk3 support, do not combine --enable-gtk3 with --without-system-cairo])
+ add_warning 'Non-system cairo combined with gtk3 is assumed to cause trouble; proceed at your own risk.'
fi
: ${with_system_cairo:=yes}
PKG_CHECK_MODULES(GTK3, gtk+-3.0 >= 3.20 gtk+-unix-print-3.0 gmodule-no-export-2.0 glib-2.0 >= 2.38 cairo)