summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuboš Luňák <l.lunak@collabora.com>2020-03-23 16:28:53 +0100
committerLuboš Luňák <l.lunak@collabora.com>2020-03-23 18:46:43 +0100
commit5feadfad0cc3be2680213d2e5f6f786b2f4cc74f (patch)
tree604565a5381728e2280a9438ec1515d9f4ea60f0 /configure.ac
parent05022d6cfff72d26fa3b916a4f86ac6488298dac (diff)
actually export $NINJA from configure
I based the check on the gmake check, but that one doesn't need the export, as gmake is what needs to be called for the build to start. But ninja is currently only used during building NSS. Also do not use Windows path for ninja on Windows, as NSS actually invokes it from a shell script. Change-Id: I0d8a86ee3688f27a376d547cd946bb4c59a547a2 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/90922 Tested-by: Jenkins Reviewed-by: Luboš Luňák <l.lunak@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index ec8c92af30f6..5e20fc4d4271 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9703,9 +9703,9 @@ for a in "$NINJA" ninja ninja-build; do
$a --version > /dev/null 2>/dev/null
if test $? -eq 0; then
if test "$build_os" = "cygwin"; then
- # nss requires the Windows version of ninja
+ # nss requires the Windows version of ninja (but uses its Unix path)
if test -n "$($a -t list | grep 'msvc')" ; then
- NINJA="$(cygpath -m "$(which "$(cygpath -u $a)")")"
+ NINJA=`which $a`
fi
else
NINJA=`which $a`
@@ -9724,6 +9724,7 @@ fi
if test -z "$NINJA" -a "$nss_needs_ninja" = "yes" -a -n "$ENABLE_NSS" -a -z "$SYSTEM_NSS"; then
AC_MSG_ERROR([Not found. NSS build requires Ninja (https://ninja-build.org/).])
fi
+AC_SUBST(NINJA)
dnl ===================================================================
dnl Check for TLS/SSL and cryptographic implementation to use