summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Foley <pefoley2@pefoley.com>2016-01-17 14:26:28 -0500
committerjan iversen <jani@documentfoundation.org>2016-01-18 07:31:47 +0000
commit7228e5dc9776e033b1cfb590ecde0be5ef5ff2b7 (patch)
tree63b15ee91bfffc187be2a9f2dfb1d4eab03fc6ef /configure.ac
parent3a079aec09d2050ee9283262e932efe6aff504cf (diff)
Fix cross-compilation with in-tree ndk/sdk
The build configure run tries to use the ndk as well. Prevent this by only auto-detecting the ndk when cross-compiling. Change-Id: I0c098a7ae3f34cd6210f1b6b14121f62ed892b13 Reviewed-on: https://gerrit.libreoffice.org/21547 Reviewed-by: jan iversen <jani@documentfoundation.org> Tested-by: jan iversen <jani@documentfoundation.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index d814673f36bd..47980c593f37 100644
--- a/configure.ac
+++ b/configure.ac
@@ -340,7 +340,7 @@ AC_ARG_WITH(android-sdk,
,)
ANDROID_NDK_HOME=
-if test -z "$with_android_ndk" -a -e "$SRC_ROOT/external/android-ndk"; then
+if test -z "$with_android_ndk" -a -e "$SRC_ROOT/external/android-ndk" -a "$build" != "$host"; then
with_android_ndk="$SRC_ROOT/external/android-ndk"
fi
if test -n "$with_android_ndk"; then
@@ -568,7 +568,7 @@ dnl ===================================================================
dnl --with-android-sdk
dnl ===================================================================
ANDROID_SDK_HOME=
-if test -z "$with_android_sdk" -a -e "$SRC_ROOT/external/android-sdk-linux"; then
+if test -z "$with_android_sdk" -a -e "$SRC_ROOT/external/android-sdk-linux" -a "$build" != "$host"; then
with_android_sdk="$SRC_ROOT/external/android-sdk-linux"
fi
if test -n "$with_android_sdk"; then