summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Holesovsky <kendy@collabora.com>2014-10-13 10:19:25 +0200
committerJan Holesovsky <kendy@collabora.com>2014-10-13 10:21:36 +0200
commit02119a79c176f08aebd7a3068e5fa05eaded1f7a (patch)
treec1ed001bc5be1a499c7441994c31aa7e9ad4d38a /configure.ac
parent1c8695ecf65174298ebd9edb5b0289db07af98ca (diff)
android: When debugging, the installLocation must be "internalOnly".
Otherwise the gdbserver ends up with run-as: exec failed for /data/data/org.libreoffice/lib/gdbserver Error:Permission denied (you need to run ndk-gdb with --verbose to see that). Change-Id: Iccdf0ff268c20d2fb5abc1e93404375fa51c1cf1
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 13 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index f05034da0873..2572e96f88d8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3751,24 +3751,28 @@ AC_MSG_CHECKING([whether to do a debug build])
if test -n "$enable_debug" && test "$enable_debug" != "yes" && test "$enable_debug" != "no"; then
AC_MSG_ERROR([--enable-debug now accepts only yes or no, use --enable-selective-debuginfo])
fi
-if test -n "$ENABLE_DBGUTIL"; then
- if test "$enable_debug" = "no"; then
- AC_MSG_ERROR([--disable-debug cannot be used with --enable-dbgutil])
- fi
- ENABLE_DEBUG="TRUE"
- ANDROID_DEBUGGABLE='android:debuggable="true"'
- AC_MSG_RESULT([yes (dbgutil)])
-elif test -n "$enable_debug" && test "$enable_debug" != "no"; then
+if test -n "$ENABLE_DBGUTIL" -a "$enable_debug" = "no"; then
+ AC_MSG_ERROR([--disable-debug cannot be used with --enable-dbgutil])
+fi
+
+if test -n "$ENABLE_DBGUTIL" -o \( -n "$enable_debug" -a "$enable_debug" != "no" \) ; then
ENABLE_DEBUG="TRUE"
ANDROID_DEBUGGABLE='android:debuggable="true"'
- AC_MSG_RESULT([yes])
+ ANDROID_INSTALL_LOCATION='android:installLocation="internalOnly"'
+ if test -n "$ENABLE_DBGUTIL" ; then
+ AC_MSG_RESULT([yes (dbgutil)])
+ else
+ AC_MSG_RESULT([yes])
+ fi
else
ENABLE_DEBUG=""
ANDROID_DEBUGGABLE=""
+ ANDROID_INSTALL_LOCATION='android:installLocation="preferExternal"'
AC_MSG_RESULT([no])
fi
AC_SUBST(ENABLE_DEBUG)
AC_SUBST(ANDROID_DEBUGGABLE)
+AC_SUBST(ANDROID_INSTALL_LOCATION)
dnl Selective debuginfo
ENABLE_DEBUGINFO_FOR=