summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndras Timar <andras.timar@collabora.com>2013-12-21 13:44:51 -0800
committerAndras Timar <andras.timar@collabora.com>2013-12-21 13:49:33 -0800
commit0591a98155348ea640a82c1dfb69931464ae2076 (patch)
treee05adee01f3446dca36bae82ecb4481e3dea2ebc /configure.ac
parentb700e87a2dd672a9e57f087d13bdc4fb0f36411e (diff)
build fix
Change-Id: I6a2e8e69106584b6b7c9af35d4e0e79bf6ef5342
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 1ecb20fc6788..681ae8f44149 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9191,7 +9191,7 @@ AC_MSG_CHECKING([whether to plug browser plugins into LibreOffice documents])
# Obviously no such thing on iOS or Android. Also not possible when building
# 64-bit OS X code as the plugin code uses QuickTime and Carbon.
if test "$_os" != Android -a "$_os" != iOS -a \( $_os != Darwin -o "$BITNESS_OVERRIDE" = "" \) -a \
- "$enable_headless" != yes
+ "$enable_headless" != yes -a "$enable_mpl_subset" != yes
then
AC_MSG_RESULT([yes])
ENABLE_NPAPI_FROM_BROWSER=TRUE
@@ -9205,8 +9205,8 @@ dnl ===================================================================
dnl Check for NPAPI interface to plug LibreOffice into browser windows
dnl ===================================================================
AC_MSG_CHECKING([whether to plug LibreOffice into browser windows])
-if test "$_os" = WINNT -o "$_os" != Android -a "$_os" != Darwin -a "$_os" != iOS -a \
- "$enable_headless" != yes -a "$enable_gtk" != no
+if test "$enable_mpl_subset" != yes -a \( "$_os" = WINNT -o "$_os" != Android -a "$_os" != Darwin -a "$_os" != iOS -a \
+ "$enable_headless" != yes -a "$enable_gtk" != no \)
then
AC_MSG_RESULT([yes])
ENABLE_NPAPI_INTO_BROWSER=TRUE