summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2013-12-26 17:25:30 +0200
committerTor Lillqvist <tml@collabora.com>2013-12-26 17:25:30 +0200
commit286f991e5e17d7ef97e145457d0751abf6281791 (patch)
tree35559ce658288e9259dcdeec7d320a08b58ac9ec /configure.ac
parent95d5922c0290ecd9de17183a95c068592a2c5a4f (diff)
When using --with-macosx-sdk=10.8 or 9, use xcode-select -print-path
I want to be able to use of a separate Xcode installation (like a developer preview) instead of the /Applications/Xcode.app one. Change-Id: I1faa84d028a8df6b4fc61b321fd2a6cde9a0ab0f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 3 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 681ae8f44149..0792f6e803d7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2701,13 +2701,9 @@ if test $_os = Darwin; then
fi
;;
10.8|10.9)
- if test -d "/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX$with_macosx_sdk.sdk"; then
- MACOSX_SDK_PATH=/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX$with_macosx_sdk.sdk
- else
- xcodepath="`xcode-select -print-path`"
- if test -d "$xcodepath/Platforms/MacOSX.platform/Developer/SDKs/MacOSX$with_macosx_sdk.sdk"; then
- MACOSX_SDK_PATH="$xcodepath/Platforms/MacOSX.platform/Developer/SDKs/MacOSX$with_macosx_sdk.sdk"
- fi
+ xcodepath="`xcode-select -print-path`"
+ if test -d "$xcodepath/Platforms/MacOSX.platform/Developer/SDKs/MacOSX$with_macosx_sdk.sdk"; then
+ MACOSX_SDK_PATH="$xcodepath/Platforms/MacOSX.platform/Developer/SDKs/MacOSX$with_macosx_sdk.sdk"
fi
;;
esac