summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2022-03-14 23:43:35 +0200
committerTor Lillqvist <tml@collabora.com>2022-03-15 07:58:29 +0100
commit3733772279ba8968f18a9f73a3294f43aebe53ac (patch)
tree1d05f8b94fc000e3e467cbd63d8c32ac631b1a26 /configure.ac
parent860299fe04ec5a2ff0d716186d43d517006069aa (diff)
Accept macOS SDK 12.3
Change-Id: Ice469236dd79675b6fad6f7c5a244888200fea8b Reviewed-on: https://gerrit.libreoffice.org/c/core/+/131565 Tested-by: Tor Lillqvist <tml@collabora.com> Reviewed-by: Tor Lillqvist <tml@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 8 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 4011e8e5a849..f577a45423c7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3415,7 +3415,7 @@ if test $_os = Darwin; then
# The SDK in the currently selected Xcode should be found.
AC_MSG_CHECKING([what macOS SDK to use])
- for macosx_sdk in 12.1 12.0 11.3 11.1 11.0 10.15 10.14 10.13; do
+ for macosx_sdk in 12.3 12.1 12.0 11.3 11.1 11.0 10.15 10.14 10.13; do
MACOSX_SDK_PATH=`xcrun --sdk macosx${macosx_sdk} --show-sdk-path 2> /dev/null`
if test -d "$MACOSX_SDK_PATH"; then
break
@@ -3457,6 +3457,9 @@ if test $_os = Darwin; then
12.1)
MACOSX_SDK_VERSION=120100
;;
+ 12.3)
+ MACOSX_SDK_VERSION=120300
+ ;;
*)
AC_MSG_ERROR([macOS SDK $macosx_sdk is not supported])
;;
@@ -3519,8 +3522,11 @@ if test $_os = Darwin; then
12.1)
MAC_OS_X_VERSION_MIN_REQUIRED="120100"
;;
+ 12.3)
+ MAC_OS_X_VERSION_MIN_REQUIRED="120300"
+ ;;
*)
- AC_MSG_ERROR([with-macosx-version-min-required $with_macosx_version_min_required is not a supported value, supported values are 10.13--12.1])
+ AC_MSG_ERROR([with-macosx-version-min-required $with_macosx_version_min_required is not a supported value, supported values are 10.13--12.3])
;;
esac