summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2013-12-19 23:22:04 +0200
committerTor Lillqvist <tml@collabora.com>2013-12-19 23:28:33 +0200
commit969bd8aa731935566a65c5e207ece6eb523df24e (patch)
treef5b616385ad3a4f864a4beaadf70c92543118290 /configure.ac
parent9b711d6da2f04dd7f0bd838854768bd36d353ca1 (diff)
Use embedded DWARF in the iOS apps except for in release build
Running dsymutil takes much too long to be bearable during development. But when building for actual release we do want a separate dSYM of course. (Of course none of the current iOS apps in the source are intended to be actually "released". But add this logic just for completeness.) Change-Id: Ibb5037d6926e969a891269d6c9d86232bc01cb3c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1734796ed26f..b0a3d6a89da3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3865,6 +3865,13 @@ else
fi
AC_SUBST(ENABLE_SYMBOLS)
+# Running dsymutil takes too long
+XCODE_DEBUG_INFORMATION_FORMAT=dwarf-with-dsym
+if test "$enable_release_build" != yes -a \( -n "$ENABLE_SYMBOLS" -o -n "$ENABLE_DEBUG" -o -n "$ENABLE_DBGUTIL" \); then
+ XCODE_DEBUG_INFORMATION_FORMAT=dwarf
+fi
+AC_SUBST(XCODE_DEBUG_INFORMATION_FORMAT)
+
# Check for explicit A/C/CXX/OBJC/OBJCXX/LDFLAGS.
# By default use the ones specified by our build system,
# but explicit override is possible.