summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Weghorn <m.weghorn@posteo.de>2023-12-08 15:20:04 +0100
committerXisco Fauli <xiscofauli@libreoffice.org>2023-12-11 20:51:34 +0100
commita9a882929bd7ed2d1c5a1bc68a912d0f6de301af (patch)
tree6e57098d2cd9add55d6223879c4c2f019a757ea1 /configure.ac
parentdfb863c70fb0e924fdd053089a40cbcdd3dc5839 (diff)
configure: Pass '--auto-servernum' to xvfb-run here, too
Pass that param in configure.ac as well, to avoid multiple instances of xvfb-run potentially getting into each other's way. See the commit message of commit ca01deadcbc480b6e79618b227a2b73a61ecb7ff Author: Michael Weghorn <m.weghorn@posteo.de> Date: Mon Oct 16 11:03:46 2023 +0200 gtk3 a11y test: Let xvfb-run auto-determine free server num for more details, which added that param at the place where the tests using xvfb-run are run. Maybe this has a positive effect on occasional test failures like [1]: checking for xvfb-run... /usr/bin/xvfb-run checking whether /usr/bin/xvfb-run works...... no configure: error: xvfb-run required by --enable-atspi-tests not found Error running configure at ./autogen.sh line 321. [1] https://ci.libreoffice.org/job/gerrit_linux_gcc_release/154929/console Change-Id: Ie7ba6ec58ea44e5cf8a52d18f0359d3c2335a4ed Reviewed-on: https://gerrit.libreoffice.org/c/core/+/160466 Tested-by: Jenkins Reviewed-by: Michael Weghorn <m.weghorn@posteo.de> (cherry picked from commit 5829cf7e96d3b2fcbc91b9c5c15438202629bc03) Reviewed-on: https://gerrit.libreoffice.org/c/core/+/160579 Reviewed-by: Xisco Fauli <xiscofauli@libreoffice.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e7886b44507a..ddc3ef9d1a1a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11856,7 +11856,7 @@ if ! test "$enable_atspi_tests" = no; then
if ! test "$XVFB_RUN" = no; then
dnl make sure the found xvfb-run actually works
AC_MSG_CHECKING([whether $XVFB_RUN works...])
- if $XVFB_RUN true >&AS_MESSAGE_LOG_FD 2>&AS_MESSAGE_LOG_FD; then
+ if $XVFB_RUN --auto-servernum true >&AS_MESSAGE_LOG_FD 2>&AS_MESSAGE_LOG_FD; then
AC_MSG_RESULT([yes])
else
AC_MSG_RESULT([no])