summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2019-06-04 23:36:47 +0300
committerTor Lillqvist <tml@collabora.com>2019-10-30 11:12:59 +0100
commitaa3383affadbf16ea3588c564c0709cb34df3252 (patch)
treeec1c16c83a1f1ef40ab2f4f154d4fae1fb3f1ec0 /configure.ac
parent96d3c1ad905e4c694df4dccba51079b8f0a54d32 (diff)
Accept also macOS SDK 10.15
Change-Id: I2369db6b76af67d71146903c081ce6427d45c211 (cherry picked from commit 4378eae8aa5f29d02ac02000ba0d3a769b27c18e) Reviewed-on: https://gerrit.libreoffice.org/81731 Tested-by: Jenkins Reviewed-by: Tor Lillqvist <tml@collabora.com> Tested-by: Tor Lillqvist <tml@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 13 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 94832cdeecc0..b9fb4765932a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2735,7 +2735,7 @@ if test $_os = Darwin -o $_os = iOS; then
# higher than or equal to the minimum required should be found.
AC_MSG_CHECKING([what macOS SDK to use])
- for _macosx_sdk in ${with_macosx_sdk-10.14 10.13 10.12}; do
+ for _macosx_sdk in ${with_macosx_sdk-10.15 10.14 10.13 10.12}; do
MACOSX_SDK_PATH=`xcrun --sdk macosx${_macosx_sdk} --show-sdk-path 2> /dev/null`
if test -d "$MACOSX_SDK_PATH"; then
with_macosx_sdk="${_macosx_sdk}"
@@ -2773,8 +2773,11 @@ if test $_os = Darwin -o $_os = iOS; then
10.14)
MACOSX_SDK_VERSION=101400
;;
+ 10.15)
+ MACOSX_SDK_VERSION=101500
+ ;;
*)
- AC_MSG_ERROR([with-macosx-sdk $with_macosx_sdk is not a supported value, supported values are 10.12--14])
+ AC_MSG_ERROR([with-macosx-sdk $with_macosx_sdk is not a supported value, supported values are 10.12--15])
;;
esac
@@ -2819,8 +2822,11 @@ if test $_os = Darwin -o $_os = iOS; then
10.14)
MAC_OS_X_VERSION_MIN_REQUIRED="101400"
;;
+ 10.15)
+ MAC_OS_X_VERSION_MIN_REQUIRED="101500"
+ ;;
*)
- AC_MSG_ERROR([with-macosx-version-min-required $with_macosx_version_min_required is not a supported value, supported values are 10.10--14])
+ AC_MSG_ERROR([with-macosx-version-min-required $with_macosx_version_min_required is not a supported value, supported values are 10.10--15])
;;
esac
MAC_OS_X_VERSION_MIN_REQUIRED_DOTS=$with_macosx_version_min_required
@@ -2860,8 +2866,11 @@ if test $_os = Darwin -o $_os = iOS; then
10.14)
MAC_OS_X_VERSION_MAX_ALLOWED="101400"
;;
+ 10.15)
+ MAC_OS_X_VERSION_MAX_ALLOWED="101500"
+ ;;
*)
- AC_MSG_ERROR([with-macosx-version-max-allowed $with_macosx_version_max_allowed is not a supported value, supported values are 10.10--14])
+ AC_MSG_ERROR([with-macosx-version-max-allowed $with_macosx_version_max_allowed is not a supported value, supported values are 10.10--15])
;;
esac