summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Holesovsky <kendy@collabora.com>2015-01-22 08:35:40 +0100
committerMiklos Vajna <vmiklos@collabora.co.uk>2015-01-26 10:27:43 +0100
commitae924ed3d0a3a9b4f8438c4f1187d8378777bf92 (patch)
tree060ade2c414c020839cd6ac196fd38980aa81aef /configure.ac
parent2d584cb7cc5c5b14d3e158690fb30cd2866ab7c5 (diff)
android: Rename 'make sign' to 'make release-apk'.
This now also allows to specify the version number; now you want to use: cd android/ make versionCode=<previous_version_num+1> key=<key_name> release-apk Change-Id: I078e8dbbe671969fc3b228ac987cdb9a4a53b281
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 1 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 8ae285280676..484de1336c38 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3789,8 +3789,6 @@ fi
if test -n "$ENABLE_DBGUTIL" -o \( -n "$enable_debug" -a "$enable_debug" != "no" \) ; then
ENABLE_DEBUG="TRUE"
- ANDROID_DEBUGGABLE='android:debuggable="true"'
- ANDROID_INSTALL_LOCATION='android:installLocation="internalOnly"'
if test -n "$ENABLE_DBGUTIL" ; then
AC_MSG_RESULT([yes (dbgutil)])
else
@@ -3798,13 +3796,9 @@ if test -n "$ENABLE_DBGUTIL" -o \( -n "$enable_debug" -a "$enable_debug" != "no"
fi
else
ENABLE_DEBUG=""
- ANDROID_DEBUGGABLE=""
- ANDROID_INSTALL_LOCATION='android:installLocation="preferExternal"'
AC_MSG_RESULT([no])
fi
AC_SUBST(ENABLE_DEBUG)
-AC_SUBST(ANDROID_DEBUGGABLE)
-AC_SUBST(ANDROID_INSTALL_LOCATION)
if test "$enable_sal_log" = yes; then
ENABLE_SAL_LOG=TRUE
@@ -4420,7 +4414,6 @@ if test "$cross_compiling" = "yes"; then
bin/get_config_variables \
solenv/bin/getcompver.awk \
solenv/inc/langlist.mk \
- android/experimental/LOAndroid3/AndroidManifest.xml.in \
config_host.mk.in \
Makefile.in \
lo.xcent.in \
@@ -12795,8 +12788,7 @@ if test -f config_host.mk; then
config_md5=`$MD5SUM config_host.mk | sed "s/ .*//"`
fi
-AC_CONFIG_FILES([android/experimental/LOAndroid3/AndroidManifest.xml
- config_host.mk
+AC_CONFIG_FILES([config_host.mk
Makefile
lo.xcent
instsetoo_native/util/openoffice.lst