summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTaichi Haradaguchi <20001722@ymail.ne.jp>2023-09-20 20:12:54 +0900
committerTaichi Haradaguchi <20001722@ymail.ne.jp>2023-10-14 08:53:14 +0200
commitc72d5d787f7a3024f2108d6d6e192b158fb144ed (patch)
treee4dc035e2639677e36eed47b4d9e92d9c4a55692 /configure.ac
parent3d0a8020f932c0e39a69e555ca4cc4ba7084d2cd (diff)
tdf#116412 include bz2 module in internal python
This commit includes the changes in 5e3510dbb62229cfb01da371d39ecc27b0d44880 and 219bef04b7084eef49e1001312e186f390f4f735, as well as the following changes: * add bzip2 as permissable build target when cross compiling for Windows ARM64. * add external/bzip2/disable-test.patch.0 for cross-compiling. * revert the changes to configure.ac in 5e3510dbb62229cfb01da371d39ecc27b0d44880. * change the argument of gb_UnpackedTarball_fix_end_of_line. Change-Id: Iad8b1ed48d6c56e1302d9ac11620dc8084e79276 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/157101 Tested-by: Taichi Haradaguchi <20001722@ymail.ne.jp> Reviewed-by: Taichi Haradaguchi <20001722@ymail.ne.jp>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index f04904541cdc..32c2eecfbc7a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2199,7 +2199,8 @@ AC_ARG_WITH(system-libs,
AC_ARG_WITH(system-bzip2,
AS_HELP_STRING([--with-system-bzip2],
- [Use bzip2 already on system. Used only when --enable-online-update=mar]),,
+ [Use bzip2 already on system. Used when --enable-online-update=mar
+ or --enable-python=internal]),,
[with_system_bzip2="$with_system_libs"])
AC_ARG_WITH(system-headers,
@@ -5827,6 +5828,7 @@ if test "$cross_compiling" = "yes"; then
PERMITTED_BUILD_TARGETS="
AVMEDIA
BOOST
+ BZIP2
CAIRO
CLUCENE
CURL
@@ -13593,7 +13595,7 @@ dnl ===================================================================
dnl Test whether we need bzip2
dnl ===================================================================
SYSTEM_BZIP2=
-if test "$ENABLE_ONLINE_UPDATE_MAR" = "TRUE"; then
+if test "$ENABLE_ONLINE_UPDATE_MAR" = "TRUE" -o "$enable_python" = internal; then
AC_MSG_CHECKING([whether to use system bzip2])
if test "$with_system_bzip2" = yes; then
SYSTEM_BZIP2=TRUE